Originally Posted by Catacaustic
Why would you choose CentOs 6 when you can choose CentOs 7?

And if you need to run a website, what makes you think that LAMP is not right? What do you think you need for this? You're doing everything in PHP, so a basic LAMP stack is what you'd need to run it. Do you not understand what you actually need, or do you think that there's something else that you need that's "not standard"???
Few wks back, i think I read CentOs 7 was not stable and most softwares are compatible with 6. Hence the choice I made few wks back to go for 6.
But you are right. If 7 is available and lamp is compatible with it then why not go for the latest ? Afterall, my main softwares are apache, mysql, php and Lamp has them.