Thread: Just Jesus

    #1
  1. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2016
    Location
    Lakewood, WA
    Posts
    218
    Rep Power
    17

    Just Jesus


    For a variety of reasons I bailed on Comcast and now have CenturyLink. The main reason was Comcast was bleeding me dry, but there were other considerations also. There may come a day when I get to the same point with CenturyLink, and then I'll switch back. Whoever lays fiber optic to my door gets me first.

    ANYWAY...

    I'm running Linux on my home machine, of course.

    Any way to get rid of the ****ing CenturyLink search **** that loads when ever I have spelling mistakes in the browser bar?

    Probably a modem setting because I don't see any options in my CenturyLink account?

    The modem appears to be a "Technicolor C2100T". Never heard of it.
  2. #2
  3. Lazy Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    16,435
    Rep Power
    9645
    That's either a browser or DNS thing, and being on Linux it's probably not the browser.

    Change your nameservers to be 8.8.8.8 and 8.8.4.4 to use Google's instead of what's inherited through DHCP/the modem, or you can use someone else's.
  4. #3
  5. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2016
    Location
    Lakewood, WA
    Posts
    218
    Rep Power
    17
    There are a variety of settings:

    * Dynamic DNS - two states, Enable and Disable. It is disabled.
    * DNS Host Mapping - I can assign an IP, and IP Name, and the Device Name is by default and non-editable "WAN"

    I wonder... Could I do something with my Host file?

    I'd rather do it in the modem because I have other devices...
  6. #4
  7. Lazy Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    16,435
    Rep Power
    9645
    Found it: use custom DNS servers (step 9) of 8.8.8.8 and 8.8.4.4.

    What (I assume) is happening is
    1. You type in a domain but make a typo
    2. The computer, modem, and CenturyLink try to find the domain
    3. They fail
    4. CenturyLink's DNS (what looked up the domain) does not return the failure but instead replies with an IP address for one of their servers
    5. Your computer has no idea that happened, assumes that address is the right one for the domain, and dutifully tries to go there
    6. Their server is set up so that trying to use it for some domain redirects you to a search page

    If you try
    Code:
    https://www.whatevertypoeddomainname.com
    (note the "https") then your browser should warn you about Something Being Wrong.
  8. #5
  9. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,553
    Rep Power
    4549
    It's probably a CenturyLink "Feature" that you may not be able to cure. Some isp's dns servers take advantage of not found domain names to do a little free advertising, etc. A couple years ago Verizon did this with their DNS servers, and had to provide different DNS servers that would act correctly and return non-existent domain rather than returning a redirected address.

    If you're not locked in to using your ISP dns servers then using Google's or other free DNS servers should be the answer.

    Oh, btw fiber is great, I'm on year 10+ of FIOS.
    ======
    Doug G
    ======
    I've never been able to appreciate the sublime arrogance of folks who feel they were put on earth just to save other folks from themselves .." - Donald Hamilton

IMN logo majestic logo threadwatch logo seochat tools logo