Page 1 of 2 12 Last
  • Jump to page:
    #1
  1. No Profile Picture
    guest
    Guest
    Devshed Newbie (0 - 499 posts)

    Problem


    <p><pre><font color=#008000><xmp>
    ?xml version=
  2. #2
  3. No Profile Picture
    guest
    Guest
    Devshed Newbie (0 - 499 posts)

    Re: Problem


    Some admin had better put the code between
    Code:
     and
    :)
  4. #3
  5. No Profile Picture
    guest
    Guest
    Devshed Newbie (0 - 499 posts)

    so where is the error


    ok there is an error in the script when it comes to create the $dom object with an external file ($dom = xmldocfile($file);)
    I am a newby, i am not able to find the error, where does it comes from ? The .xml file ?
    Thank you for an answer
    thomas
    (french speaker)
  6. #4
  7. No Profile Picture
    guest
    Guest
    Devshed Newbie (0 - 499 posts)

    It's a test


    Uma xopa na lombeta de todo mundo q ta lendo isso!!!

    hehehe!
  8. #5
  9. No Profile Picture
    guest
    Guest
    Devshed Newbie (0 - 499 posts)

    Re: It's a test


    Isto q vc teclou is so beautifull!!!
  10. #6
  11. No Profile Picture
    guest
    Guest
    Devshed Newbie (0 - 499 posts)

    HTML in XML??


    Is there anyway to store HTML in XML?

    <BOOK>
    <TITLE>title</TITLE>
    <WEBSITE><a href=http:/www.website.com</a></WEBSITE>

    When I try to parse the XML in PHP, it gives me errors. I could see why this is, just wondering if anyone has had to solve this problem before?
  12. #7
  13. No Profile Picture
    guest
    Guest
    Devshed Newbie (0 - 499 posts)

    Error using DOM


    Hello,

    I tried to parse XML string using the DOM methode

    All I got is an error:

    Fatal error: Call to a member function on a non-object in ...

    on: $root = $dom->root();

    I don't know why, I'm running under WIN2K and the domxml extension is loaded...

    any idea??

    Thanks in advance,

    Xavier
  14. #8
  15. No Profile Picture
    guest
    Guest
    Devshed Newbie (0 - 499 posts)

    PHP function xmldocfile () ...does it exists?


    >ok there is an error in the script when it
    >comes to create the $dom object with an
    >external file ($dom = xmldocfile($file);)

    xmldocfile(),xmldoc(), xmltree()

    There are not such functions in PHP 4.0
    manual.
    There are not such functions in
    "Professional PHP programming".

    That's why the paragraph from

    http://www.devshed.com/Client_Side/XML/XMLwithPHP2/page2.html

    "PHP offers three functions to do this: the xmldoc() and xmltree() functions accept a string containing XML data as argument, and build a tree structure from that string, while the xmldocfile() function accepts a filename as argument, and builds a DOM tree after reading the data in the file."


    sounds confusing to me.

    And I would like some clarification on the existence of these functions.
  16. #9
  17. No Profile Picture
    guest
    Guest
    Devshed Newbie (0 - 499 posts)

    So I've finally found the discription in French


    http://www.php.net/manual/fr/ref.domxml.php

    Maybe this may help!
  18. #10
  19. No Profile Picture
    guest
    Guest
    Devshed Newbie (0 - 499 posts)

    Re: HTML in XML??


    I've got a similar problem with both URLs and Mailto: links. If you find a solution, I'd appreciate knowing about it.

    I've tried various things such as XSL attributes, various formattings of the embedded HTML, all with no result.

    I've asked in several forums, but with little or no useful response so far.

    Alan S>
  20. #11
  21. No Profile Picture
    guest
    Guest
    Devshed Newbie (0 - 499 posts)

    Re: HTML in XML??


    I found a partial answer, using XSL Style Sheets to do the transformation (at last!), in the XSL-List archives:

    <xsl:if test="WEB[.!='']">
    <a>
    <xsl:attribute name="href">http://<xsl:value-of select="WEB"/>
    </xsl:attribute>
    <xsl:attribute name="target">_blank</xsl:attribute>
    <xsl:value-of select="WEB"/></font></li>
    </a>
    </xsl:if>

    But this does require that the XML data only has the stuff after the 'http://'

    It works for me...
  22. #12
  23. No Profile Picture
    guest
    Guest
    Devshed Newbie (0 - 499 posts)

    Re: So I've finally found the discription in French


    Thank you !
  24. #13
  25. No Profile Picture
    guest
    Guest
    Devshed Newbie (0 - 499 posts)

    Re: Error using DOM


    I have exactly the same problem. Do you know how to resolve it ?
  26. #14
  27. No Profile Picture
    guest
    Guest
    Devshed Newbie (0 - 499 posts)

    Re: Error using DOM


    Nope I didn't solve the problem...I think I'll install the sablotron extension on my server to use PHP, XML and XSLT...

    but if someone has the answer I'd be interesed !!

    thx in advance
  28. #15
  29. No Profile Picture
    guest
    Guest
    Devshed Newbie (0 - 499 posts)

    Re: Error using DOM


    Xavier,

    everybody around the web seems to have the same pb as us.

    I already installed xslt extension and xml sax. It works fine.
Page 1 of 2 12 Last
  • Jump to page:

IMN logo majestic logo threadwatch logo seochat tools logo