#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2013
    Location
    New York
    Posts
    6
    Rep Power
    0

    I am lock out of the admin program "Joomla"


    Thank you for reading my post. I run a website from home which has been running very well until lately. I wanted to get some insight on how many users were using the site and the peek times of uses. So I attempted to install piwik to view the stats. After installing and configuring the program I got this error.
    Table './joomla/upo2w_session' is marked as crashed and last (automatic?) repair failed SQL=INSERT INTO `upo2w_session` (`session_id`, `client_id`, `time`) VALUES ('ggd9l4r4tqmjf3ouhvuidg48o1', 0, '1386084528')
    Now the system (The content management program) will not display pages and I am lock out of the admin program "Joomla" I am hoping that there is an easy fix for this. After 8 years of running Mysql I'm just starting to see the need to really understand the program.
  2. #2
  3. Code Monkey V. 0.9
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Mar 2005
    Location
    A Land Down Under
    Posts
    2,066
    Rep Power
    1990
    That's no an error with Joomla or anything else. One of your database tables has become corrupted and crashed. The error message says exactly what the problem is.

    The only solution is to restore that table or the entire database from the last-known working backup that you have. You do have backups, don't you???
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2013
    Location
    New York
    Posts
    6
    Rep Power
    0

    Will check that thanks


    yes I have made a back-up. But I got an error when I tried. Let me try again (upon access of the system) to get the error and get back to you. Thanks again for the quick reply.
    Still think piwik install had a part in it (Now un-installed)
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2013
    Location
    New York
    Posts
    6
    Rep Power
    0

    here is the error


    Originally Posted by adinkrahene
    yes I have made a back-up. But I got an error when I tried. Let me try again (upon access of the system) to get the error and get back to you. Thanks again for the quick reply.
    Still think piwik install had a part in it (Now un-installed)
    I get this error when do the restore
    Error during backup. Table 'upo2w_allvideoshare_adverts' already exists
    Thanks in advance for the help..
  8. #5
  9. Code Monkey V. 0.9
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Mar 2005
    Location
    A Land Down Under
    Posts
    2,066
    Rep Power
    1990
    Originally Posted by adinkrahene
    yes I have made a back-up. But I got an error when I tried.
    I hope that I'm wrong with whta I think you mean, but...

    There's no point in making a back up now. You have to use a back up that was done before the problem occurred. You can't fix a broken table with a backup of a broken table.

    On the other hand, if you're trying to restore a backup that you took before the problem, them you should be able to. If you have problems you should contact your hosting company. They will probably charge you for their time spent doing it, but they'll be able to restore most backups.
  10. #6
  11. Code Monkey V. 0.9
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Mar 2005
    Location
    A Land Down Under
    Posts
    2,066
    Rep Power
    1990
    Originally Posted by adinkrahene
    I get this error when do the restore
    That error means that you're trying to add tables that are already there. You'll need to drop all of the DB tables before you try to restore them again.
  12. #7
  13. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2013
    Location
    New York
    Posts
    6
    Rep Power
    0
    Can't call my provider because I set this up on a Linux box from home.
    As you can see, I know just enough to be dangerous. I am using MYSql administrator program to work with the database. I don't see anything about dropping table here, so I will have to use the shell. But 1st I'll need to find the command to do that. You've been a big help!
  14. #8
  15. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2013
    Location
    New York
    Posts
    6
    Rep Power
    0
    Originally Posted by adinkrahene
    Can't call my provider because I set this up on a Linux box from home.
    As you can see, I know just enough to be dangerous. I am using MYSql administrator program to work with the database. I don't see anything about dropping table here, so I will have to use the shell. But 1st I'll need to find the command to do that. You've been a big help!
    Do you have any idea why this might have happened?
    I hope to avoid this if I can.
  16. #9
  17. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2013
    Location
    New York
    Posts
    6
    Rep Power
    0

    Your the Man!


    That worked like a charm, as stated in the title, your the man!
    Thanks...
    http://geneticmemory.org
  18. #10
  19. Code Monkey V. 0.9
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Mar 2005
    Location
    A Land Down Under
    Posts
    2,066
    Rep Power
    1990
    Originally Posted by adinkrahene
    Do you have any idea why this might have happened?
    Sometimes MySQL database tables get corrupted. It "just happens". Most times it's from an issue with the server or there's an interruption in a write process or even a disk block or I/O error, but there's no definitive answer.

    All you can do is keep backups - and that's what you should be doing anyway. That way when (not if, when) something goes wrong, you can revert to the last known stable version and keep going.
  20. #11
  21. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2013
    Location
    Auckland, New Zealand
    Posts
    3
    Rep Power
    0

    Thumbs up


    Hosting locally might not be the best idea either.

    There is cheap hosting for literally $5 USD a month.

    Also, remember to always use the latest version of Joomla where possible.

    Anything prior to 1.7 is now obsolete and no longer supported.
  22. #12
  23. Code Monkey V. 0.9
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Mar 2005
    Location
    A Land Down Under
    Posts
    2,066
    Rep Power
    1990
    Hosting locally doesn't make any difference at all. You still need to keep and maintain regular backups no matter where you host your site. If you don't this will happen again regardless of if it's in your home or on a multi-million $ server farm somewhere.

IMN logo majestic logo threadwatch logo seochat tools logo