#1
  1. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2011
    Posts
    105
    Rep Power
    51

    DNS doesnt resolve on first try?


    I have lately moved some of my sites to a new host. (3 weeks ago) However, my network seems to have trouble resolving the domains I think.

    Whenever I visit one of the websites after rebooting my pc, it will not load, until i refresh the page. The same goes for FTP, which wont connect only until the second try. I'm using the IP of the server for FTP.

    Whenever I connected to it once, it will work for the entire time the computer is on.

    What could be causing this?

    One of the sites is: http://wordfeudoppc.nl.

    I'm also curious if im the only one, and if its not a server-side problem.

    It also happens on other computers on the network, and on my phone connected to the wifi. I have also tried on my mobile network, but I cant be sure, since i just tried with the wifi
    Last edited by Rhytz; January 7th, 2013 at 05:27 AM.
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2011
    Posts
    289
    Rep Power
    44
    What you are experiencing is a DNS timeout. It failed to get the answer on the first attempt in time, but by the time you refreshed it had the answer. After that the answer was in cache.

    The problem is not necessarily with the authoritative name servers, but with the DNS servers your computer is using to get the answer. The only solution is to use different DNS servers that will respond more quickly (eg. opendns).

    J.A. Coutts
  4. #3
  5. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2011
    Posts
    105
    Rep Power
    51
    I am already using OpenDNS How come the IP doesnt resolve either in the FTP?

    Do you encounter the same problem when visiting the website?
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2011
    Posts
    289
    Rep Power
    44
    Originally Posted by Rhytz
    I am already using OpenDNS How come the IP doesnt resolve either in the FTP?

    Do you encounter the same problem when visiting the website?
    It does not matter which program you use, it all requires client DNS resolution. When I tested your domain, it resolved almost immediately. That meant that the DNS servers I am using (Telus) already had the domain in cache, and did not need to use Recursion to obtain it from the authoritative server. The OpenDNS servers do not have a very long Time To Live (TTL), so they are dropped from cache quite quickly. Although your domain resolved quickly, I do experience the same thing occasionally on other domains. If you can find DNS servers that are close (your own ISP) and responsive, they are usually the best. I used a program called "dnstester" to find the best servers for me. Google also provides public DNS servers, but again they can have a long transit time, depending on your location. Do not use more than two. On a bad lookup, it has to time out on all servers, and that could take a long time if you have several configured.

    J.A. Coutts
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2012
    Location
    Brooklyn, NYC
    Posts
    34
    Rep Power
    2
    Most likely It's not a server-side issue if you connect via FTP with direct IP. Try to install sniffer (ex. Fiddler) and look through the log of your connections. Also check your firewall.
  10. #6
  11. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2011
    Posts
    105
    Rep Power
    51
    Thanks for the answers

    It seems the problem has resolved itself by now.
    Post to Facebook using a Nokia 3310

IMN logo majestic logo threadwatch logo seochat tools logo