#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2001
    Posts
    10
    Rep Power
    0

    Forced to use FQDN on LAN


    Hi,

    I have a LAN of 3 computers all running RedHat Linux 7.1. The three computers are named mach1, mach2, and mach3, and the domain is log.cabin. mach1 is the "main" machine and runs Apache, bind, and a buch of other currently irrelevant daemons.

    mach1 has a firewall, but it doesn't block anything from the local net. I've set up the bind config files to be authoritative for the log.cabin zone.

    If I run 'host mach1' from any of the 3 machines, I get an immediate answer. However, if I 'dig mach1' from any machine (including mach1), it times out. 'dig mach1.log.cabin' works fine. When I ssh or telnet to mach1, I have to specify the FQDN or it takes a very long time.

    The funny thing is, I can run 'dig mach2' or 'dig mach3', and get immediate responses. Also, the delay does not exist when I am connected to my ISP (dialup modem...don't use their nameservers).

    I can provide any config files necessary, I just didn't want to if it wasn't necessary. Anyone have any ideas?

    Thanks,
    Ben
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2001
    Posts
    4
    Rep Power
    0
    Show us your zone file, named.conf, resolv.conf and /etc/hosts file.
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2001
    Posts
    10
    Rep Power
    0
    Here are the files. I would have attached them, but it doesn't appear that more than one file can be attached. They all come from mach1. mach2 and mach3's resolv.conf and hosts files look pretty much the same. I don't recall modifying the other zone files (mentioned in named.conf), but I can post them also if needed. I didn't figure they would be relevant since log.cabin is my zone of trouble.




    One other thing--here are the IP numbers for my machines:


    mach1 == 192.168.1.40


    mach2 == 192.168.1.41 and 192.168.2.1


    mach3 == 192.168.2.2





    (I don't have a hub so mach2 has 2 ethernet cards in it, and serves as a router between the two networks.)





    Grateful for any clues,


    Ben





    -----/etc/named.conf--------


    // generated by named-bootconf.pl





    options {


    directory "/var/named";


    /*


    * If there is a firewall between you and nameservers you want


    * to talk to, you might need to uncomment the query-source


    * directive below. Previous versions of BIND always asked


    * questions using port 53, but BIND 8.1 uses an unprivileged


    * port by default.


    */


    //forward first;


    //forwarders { 208.139.151.10; 208.139.144.2; };


    // query-source address * port 53;


    };





    //


    // a caching only nameserver config


    //


    zone "." IN {


    type hint;


    file "named.ca";


    };





    zone "localhost" IN {


    type master;


    file "localhost.zone";


    allow-update { none; };


    };





    zone "0.0.127.in-addr.arpa" IN {


    type master;


    file "named.local";


    allow-update { none; };


    };


    zone "log.cabin" IN {


    type master;


    file "cabin.zone";


    allow-update { none; };


    };


    zone "168.192.in-addr.arpa" IN {


    type master;


    file "named.cabin";


    allow-update { none; };


    };





    --------/etc/hosts---------


    # Do not remove the following line, or various programs


    # that require network functionality will fail.


    127.0.0.1 localhost.localdomain localhost


    #192.168.1.40 mach1.log.cabin mach1


    #192.168.1.41 mach2.log.cabin mach2


    #192.168.2.2 mach3.log.cabin mach3





    --------/etc/resolv.conf-------


    domain log.cabin


    nameserver 192.168.1.40





    --------/var/named/cabin.zone--------


    @ 1D IN SOA mach1.log.cabin. root.mach1.log.cabin. (


    2001121000 ; serial


    3H ; refresh


    15M ; retry


    1W ; expiry


    1D ) ; minimum


    1D IN NS mach1.log.cabin.


    mach1 1D IN A 192.168.1.40


    mach2 1D IN A 192.168.1.41


    mach3 1D IN A 192.168.2.2


    newcreature 1D IN CNAME mach1


    cyclist 1D IN CNAME mach1


    ldp 1D IN CNAME mach1


    php 1D IN CNAME mach1


    apache 1D IN CNAME mach1


    css 1D IN CNAME mach1


    html 1D IN CNAME mach1


    wxpython 1D IN CNAME mach1


    wx 1D IN CNAME mach1


    python 1D IN CNAME mach1


    mysql 1D IN CNAME mach1


    xml 1D IN CNAME mach1


    cvs 1D IN CNAME mach1


    rute 1D IN CNAME mach1


    wlogan 1D IN CNAME mach1


    wblogan 1D IN CNAME mach1


    bash 1D IN CNAME mach1


    lfs 1D IN CNAME mach1


    linuxfromscratch 1D IN CNAME mach1


    maxrpm 1D IN CNAME mach1


    python2 1D IN CNAME mach1


    liec 1D IN CNAME mach1


    jargon 1D IN CNAME mach1


    becky 1D IN CNAME mach1


    jake 1D IN CNAME mach1


    jhlogan 1D IN CNAME mach1


    docbook 1D IN CNAME mach1


    povray 1D IN CNAME mach1


    pov 1D IN CNAME mach1


    ben 1D IN CNAME mach1





    ---------/var/named/named.cabin--------


    $TTL 86400


    @ IN SOA mach1.log.cabin. root.mach1.log.cabin. (


    2001121000 ; Serial


    28800 ; Refresh


    14400 ; Retry


    3600000 ; Expire


    86400 ) ; Minimum


    IN NS mach1.log.cabin.


    40.1 IN PTR mach1.log.cabin.


    41.1 IN PTR mach2.log.cabin.


    2.2 IN PTR mach3.log.cabin.





    -----The End-----

IMN logo majestic logo threadwatch logo seochat tools logo