#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2012
    Posts
    1
    Rep Power
    0

    Need some serious DNS help


    Hello all,

    I have a very puzzling issue with DNS that I'm trying to resolve and I need some expert guidance.

    I have a client that is sending DNS A requests to my server,
    the server is sending back a response, however, the "answer" section of the response packet is blank. I've been looking at it with Wireshark to verify this.

    Is this allowable behavior for DNS, can the server send back a response that isn't either NXDOMAIN or an actual resolved IP address? If so, would anyone have any idea what sort of factors would make my server do this?

    Thanks,

    redmage12
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2011
    Posts
    289
    Rep Power
    44
    This is something that I have never completely understood, but it does not appear to be contrary to RFC specs. For example, if you do a lookup for an "A" record on nomail.com, it will return a response code 0 (no error) but no answer, only an SOA record. I have been having trouble with Yahoo for ages because this is the type of response their DNS servers are expecting for type "99" records. Our server does not support type "99" records and returns a response code 4 (Not Implemented), which seems to be more appropriate, but their servers cannot handle it and keep pounding away requesting the same thing thousands upon thousands of times. Since implementing DMARC, they seem to have resolved the issue, and are now requesting TXT records instead.

    J.A. Coutts

IMN logo majestic logo threadwatch logo seochat tools logo