Hi,

I am trying to set up a DNS server with little luck and hope someone can help me.

Scenario:
I have purchased a domain name from 123-reg, aplservers.co.uk

I have a dedicated server running Ubuntu 12.04 with 2 IP addresses which are available to the www.

I need to set up a private name server so my domain name can point to the server.

I have set the name servers in the control panel of 123-reg to ns01.aplservers.co.uk and ns02.aplservers.co.uk specifying my 2 IP addressees too.

I have looked at several tutorials on how to setup a primary DNS server, but I still can't get this working.

Here is what I've done on my server:

Installed bind9.
Edited /etc/bind/named.conf.local :
Code:
zone "aplservers.co.uk" {
        type master;
        file "/etc/bind/zones/aplservers.co.uk.zone";
};

zone "124.113.82.in-addr.arpa" {
        type master;
        notify no;
        file "/etc/bind/zones/rev.113.82.80.in-addr.arpa";
};
/etc/bind/zones/aplservers.co.uk.zone :
Code:
aplservers.co.uk. IN    SOA     ns01.aplservers.co.uk. admin.aplservers.co.uk (
        2012051701;
        28800;
        3600;
        604800;
        38400 );
aplservers.co.uk. IN    NS      ns01.aplservers.co.uk.
www     IN      A       80.82.113.124
mta     IN      A       80.82.113.124
ns01    IN      A       80.82.113.124
/etc/bind/zones/rev.113.82.80.in-addr.arpa :
Code:
@ IN SOA ns01.aplservers.co.uk. admin.aplservers.co.uk. (
        2013051701;
        28800;
        604800;
        604800;
        86400 );
        IN NS ns01.aplservers.co.uk.

2       IN PTR aplservers.co.uk
When I try and ping aplservers.co.uk I just get ping: unknown host aplservers.co.uk.

Here's the whois for my domain: http://who.is/whois/aplservers.co.uk

Any ideas what I'm doing wrong?

David