#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2012
    Posts
    13
    Rep Power
    0

    Website slow on Android devices and other website response time issues..


    Hello,

    I have shared two screenshots.

    1. Pingdom monitoring report: This report for last 1 month shows that the response time of the website was more (about 12seconds) in mobile devices. Which is very high. I myself browse my site and find that the pages get stuck suddenly and dont load while other sites load pretty well. This mostly happens with 3G connections while it works abosultely well on Wi-Fi. I have also installed some tracert apps on my android mobile and found the tracert perfectly tracing to the server IP.
    So, what could be the cause of sluggishness on mobile devices and esp for my site?

    2. The report also shows that the front-end load time is high. What does this mean?
    Does it mean that the front end stuff like images are taking longer to load?

    3. Pingdom 1 month website response time report: This screenshot shows that the average website response time is around 600ms. As far as I know the website response time should be low around 300-500ms. The DNS response time is around 50-60ms but if the website response time is 600ms, then perhaps the issue should be with the server.
    Any idea on what parameters I should look into and what could be a possible solution?

    Any help from server optimization experts will help.

    Regards,

    Ravi

    Pingdom monitoring report
    Pingdom 1 month website response time report
  2. #2
  3. No Profile Picture
    Lost in code
    Devshed Supreme Being (6500+ posts)

    Join Date
    Dec 2004
    Posts
    8,317
    Rep Power
    7170
    This doesn't sound like a DNS problem. There shouldn't be anything that would cause a site's response time to differ between mobile and non-mobile connections. Based on what you've described, it sounds like the resources on the site are too large and are taking a long time to load over slow mobile connections.
    PHP FAQ

    Originally Posted by Spad
    Ah USB, the only rectangular connector where you have to make 3 attempts before you get it the right way around
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2012
    Posts
    13
    Rep Power
    0
    Originally Posted by E-Oreo
    This doesn't sound like a DNS problem. There shouldn't be anything that would cause a site's response time to differ between mobile and non-mobile connections. Based on what you've described, it sounds like the resources on the site are too large and are taking a long time to load over slow mobile connections.
    @E-Oreo: The mobile speeds of 3G is around 6-7 Mbps which is fairly good.
    Also, please check this screencast video which I have done to explain the entire problem: http://www.screenr.com/fupH

    Here is what you will notice:
    1.On normal broadband everything is working fine.
    2.As soon as I switch on to 3g, the site does not load properly.
    3.Tracert and nslookup results look fine.
    4.Other sites are working well on 3g.

IMN logo majestic logo threadwatch logo seochat tools logo