1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2013
    Rep Power

    Local DNS on Public Network

    Hi all, I believe this issue is a simple fix & I am just missing something easy.

    The issue is I cannot access websites I host publicly on public IPs. The resolve publicly just fine. everybody else can see them.

    Websites are all accessible & go through a public actiontek modem gateway 65.103.112.xxx. Each server gets internet access via a local network hub, 192.168.0.xxx, connected directly to the modem then each server is individually firewalled & each firewall forwards particular public web traffic 65.013.112.xx1 to the correct local server NIC ip 192.168.0.xx1 via port forwarding.

    I have in the past connected to the local hub with local ip ie( to get local internet access and was able to FTP to the public websites & test public websites via this method.

    Publicly it all works,. and privately I get internet access, this method & wiring worked for 10+ years.

    a recent upgrade to the DSL modem to get more bandwidth gave me a new Actiontek modem and a bonded twisted pair from CenturyLink. Great got the expected speed up & down & the public sites are still accessible via the rest of the world wide web without changing any server settings. but no website resolution of my websites on any local machine connected to the same local network. internet access is fine to any other website in the world just not the ones I host.

    I realize the modem is the only change in the equation,.. the settings of the old one and the new one I cannot make sense if one setting is different in the new one vs the old one.
    Everything seems the same. tried quite a few setting changes only to end up with same result.

    Would like to understand just what and why is,.. or is NOT occurring Not sure if one network needs to be bridged to the other. or if DNS records need to be mapped in the modem. I have the wrong DNS Servers, gateway, subnet, etc,...

    I do get answers back on Ping for both ip address & DNS.

    I thought I had a handle on DNS but this one baffles me.
    This one has dinged my DNS confidence.
    I am now more humble.

    Any thoughts?
  2. #2
  3. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Rep Power
    Here's a couple guesses. First, some routers/firewalls block "looping" out of your internal network to the public IP and back in to your lan

    Another guess, perhaps you have a leftover hosts file entry superseding the dns lookups.
    Doug G
    I've never been able to appreciate the sublime arrogance of folks who feel they were put on earth just to save other folks from themselves .." - Donald Hamilton
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Oct 2009
    Nebraska, USA
    Rep Power
    IMHO, this has nothing to do with DNS issues......your new modem/router most likely doesn't have NAT loopback feature [or if it does, its not enabled].....which would cause you not to be able to access your locally-hosted websites using the public IP.
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2011
    Rep Power
    Simply add the domain name and private IP address to the HOSTS file on each machine. Make sure you are using fixed IP addressing. Otherwise the assignment will change over time.

    J.A. Coutts

IMN logo majestic logo threadwatch logo seochat tools logo