#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2009
    Posts
    74
    Rep Power
    5

    Firebird 2.0.4 superserver install on Debian Etch i686


    Hi,

    How are you? I have some questions.

    So I have a i686 architecture Debian Etch (4)

    #uname -all

    Linux server 2.6.18-5-686 #1 SMP Mon Dec 24 16:41:07 UTC 2007 i686 GNU/Linux

    Then I want to install Firebird 2.0.4.

    Why can't I find a Firebird2.0.4-super.deb for this architecture?

    http://packages.debian.org/lenny/firebird2.0-super

    In case I have a Firebird 2.0.4 super server on Debian Lenny (5).
    Can I run this database on Firebird 1.5.6? (I think not) ?
    Can I run Firebird 2.0.4 on Debian Etch? (I think I can) ?

    Can I switch from super to classic with the same database (.gdb) file?

    If you assume that I have some problems with my Lenny server and want to use my Etch to continue --> your assumtions are right.

    Hope you can help me with my other questions.
    Sorry for my bad English.

    Cheers.

    R.

    P.s.: Of course you can try, but sometimes a server is not suited for test cases.
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2009
    Posts
    74
    Rep Power
    5
    Maybe I just go for the tarball.

    Suggestions are still welcome.
  4. #3
  5. Bug Hunter
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2003
    Location
    Transylvania (Romania)
    Posts
    309
    Rep Power
    23

    Thumbs up


    Originally Posted by rapgame
    Hi,

    How are you? I have some questions.

    So I have a i686 architecture Debian Etch (4)

    #uname -all

    Linux server 2.6.18-5-686 #1 SMP Mon Dec 24 16:41:07 UTC 2007 i686 GNU/Linux

    Then I want to install Firebird 2.0.4.

    Why can't I find a Firebird2.0.4-super.deb for this architecture?

    http://packages.debian.org/lenny/firebird2.0-super

    In case I have a Firebird 2.0.4 super server on Debian Lenny (5).

    Can I switch from super to classic with the same database (.gdb) file?
    i386 is in fact the compiler options to be safe on older cpus (think 386/486/pentium 1,2) but binary it will work on newer cpus too so this is why is called i386 binary
    So is safe to use i386 on i686 architecture

    http://www.debian.org/releases/oldst...ml.en#id583249

    to install the binary just use
    apt-get install firebird2.0-super


    it is recommended to upgrade to the current stable and install firebird 2.1.x
    http://packages.debian.org/squeeze/firebird2.1-super

    http://www.debian.org/releases/stabl...upgrading.html

    In fact i would recomment testing with firebird 2.5
    My home page: http://www.firebirdsql.org and work place :http://www.reea.net

IMN logo majestic logo threadwatch logo seochat tools logo