#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Posts
    4
    Rep Power
    0

    Firebird backup problem


    Iīm testing Firebird 1.5 RC8 with EMS IB Manager. I canīt backup, restore, validate, etc.

    All of these were ok with Interbase 6.0, but they donīt work with Firebird.

    ŋHow can I get arroud this problem?

    Thank you.
  2. #2
  3. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2003
    Location
    Bucharest
    Posts
    72
    Rep Power
    12
    it work!
    is your fb server started?
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Posts
    4
    Rep Power
    0
    Yes, the server is working ok. Only the options in "services" menu of IB Manager donīt work.

    I tried a "clean" install and had the same result.

    I think itīs some kind of API problem...
  6. #4
  7. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2003
    Location
    Bucharest
    Posts
    72
    Rep Power
    12
    - be sure that you use the right version of gds32.dll or use fbclient.dll explicit
    - try gbak, and if it works then the problem is with ibmanager (I use ibexpert and never had this problem)
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2003
    Posts
    250
    Rep Power
    15
    "gbak" is the best option if the GUI fails.

    Apparently, IBManager has a problem with the version reporting done by Firebird 1.5 ...

    There are other GUI tools that don't suffer from this, gee, I happen to know one
    Martijn Tonies
    Database Workbench: developer IDE for Firebird, MySQL, InterBase, MSSQL Server and Oracle
    Upscene Productions
    http://www.upscene.com
  10. #6
  11. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Posts
    4
    Rep Power
    0
    It seems that the Firebird instalation program creates a copy of fbclient.dll but with the name gds32.dll. I think it does this way for compatibility reasons.

    Iīm not shure what version does FB 1.5 report, but think that is 6.x for the same reasons.

    Iīm more convinced now tahat itīs a compatibility problem between IB Manager and Firebird.

    Iīll try Upsceneīs product, but is it "English only"?

    Thks
  12. #7
  13. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Posts
    4
    Rep Power
    0
    By the way, does Upsceneīs GUI use IB/FB API for backups or it uses gbak with a graphic front end?
  14. #8
  15. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2003
    Posts
    250
    Rep Power
    15
    īll try Upsceneīs product, but is it "English only"?
    Currently, yes.

    By the way, does Upsceneīs GUI use IB/FB API for backups or it uses gbak with a graphic front end
    The API.
    Martijn Tonies
    Database Workbench: developer IDE for Firebird, MySQL, InterBase, MSSQL Server and Oracle
    Upscene Productions
    http://www.upscene.com

IMN logo majestic logo threadwatch logo seochat tools logo