#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2009
    Posts
    3
    Rep Power
    0

    Can`t connect to firebird 2.1.2 remotely


    i`ve instaled firebird 2.1.2 from binary file
    and chenged firebird.conf to use fbd_gs service wich i defined at port 3060 cause i have Ineterbase 6.0.2 on 3050.

    firebird-> clasic server -> do not generate gds32.dll -> do not install fbclient in system folders.


    I`m triyng to connect to Fbird using TCP/IP from EMS studio
    /IBEXpert -> programs hangs for a while and then message cannot establish connection appears. Then i tried with local connection but the result is the same.
    Interbase works fine
    Configuration is WInXp SP3 fully updated with DElphi 2009 Profesional and VC 2008

    on other configuration with WinXp sp2 with delphi 2006 and VC 2005
    I can connect to firebird without problem.

    Could somene tell me where the prblem come from and how to correct it.

    I`ve got repeating block in Firebird.log of this type
    DANKO (Client) Wed May 13 16:16:52 2009
    INET/inet_error: connect errno = 10061


    DANKO Wed May 13 16:20:32 2009
    inet server err: setting KEEPALIVE socket option



    DANKO Wed May 13 16:20:32 2009
    inet server err: setting NODELAY socket option



    DANKO Wed May 13 16:20:32 2009
    INET/inet_error: select in packet_receive errno = 10038
    is this somekind of socket error and how should i to correct it

    update
    it realy was a socket problem
    i`ve found users with simillar problems on the net and then come the solution
    firebird`s faqs were helpfull too
  2. #2
  3. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2010
    Posts
    5
    Rep Power
    0
    Could you tell us how you solved the problem?

    I got the same problem but I canīt figure out how to solve the socket problem.

    Thanks.
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2009
    Posts
    3
    Rep Power
    0
    i`ve used following commands
    ◦netsh int ip reset
    ◦netsh winsock reset
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2010
    Posts
    5
    Rep Power
    0
    Thanks man,

    I did it, but still canīt get connected.

    Iīm trying to connect from Firebird SQL Maestro.

    If I connect with localhost it works fine, but if I put my ip address from the same machine, it doesnīt work.

    Do I have to make any other modifications in firebird.conf or something else?

    Thanks.
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2009
    Posts
    3
    Rep Power
    0
    1 do you have installed interbase if so chage the listening port in config file and pass it in database connection string
    "hostname"/"port":"database path" = localhost/3060:C:\foo.fdb

    2 what kind of error do you have in log
  10. #6
  11. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2010
    Posts
    5
    Rep Power
    0
    I solved it, simply disable the ESET NO32 Antivirus Firewall. I completly forgot it.

    Now everything is working fine.

    Thank you!

IMN logo majestic logo threadwatch logo seochat tools logo