Page 1 of 2 12 Last
  • Jump to page:
    #1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2011
    Location
    Kansas
    Posts
    14
    Rep Power
    0

    Scrolling Video Help


    I have a video that is composed of a large image that is like 2100 x200 that scrolls from right to left using action script 2 for the scrolling motion and a second image that is the company's logo that is stationary (or supposed to be) however, when the page is refreshed the logo moves from it's position at the right corner to the left corner (actually slightly off the page to the left. ). How can I get the logo to stay stationary like it is supposed to.

    Please note that I am a Flash and Action script Newb I did not write this video I am only trying to edit it for a client.

    Oh and I would like to say thanks to Tann San who previously helped me with another video project I was working on! You Rock!
  2. #2
  3. No Profile Picture
    Gotta get to the next screen..
    Devshed Supreme Being (6500+ posts)

    Join Date
    Nov 2003
    Location
    Legion of Dynamic Discord
    Posts
    6,678
    Rep Power
    3165
    Ha, words get you everywhere ^_^

    It's hard to say why the logo is moving. Going to need some more info such as any code related to moving/positioning the logo.

    Comments on this post

    • rtstone agrees
    Quis custodiet ipsos custodes?
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2011
    Location
    Kansas
    Posts
    14
    Rep Power
    0
    Originally Posted by Tann San
    Ha, words get you everywhere ^_^

    It's hard to say why the logo is moving. Going to need some more info such as any code related to moving/positioning the logo.
    Tann San,

    Hello again and thanks. I will get you the information you are requesting soon.
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2011
    Location
    Kansas
    Posts
    14
    Rep Power
    0
    Originally Posted by rtstone
    Tann San,

    Hello again and thanks. I will get you the information you are requesting soon.
    Tann San,

    I think that the information you will need is too complex to post. If you would be willing to look at it I can provide you a copy of the video.

    Thanks again!

    Robert
  8. #5
  9. No Profile Picture
    Gotta get to the next screen..
    Devshed Supreme Being (6500+ posts)

    Join Date
    Nov 2003
    Location
    Legion of Dynamic Discord
    Posts
    6,678
    Rep Power
    3165
    ok, upload it somewhere and post a link.
    Quis custodiet ipsos custodes?
  10. #6
  11. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2011
    Location
    Kansas
    Posts
    14
    Rep Power
    0
    Tann San,

    Here is a link to the file I need help with.

    http://www.stonesolidwebdesign.com/scroll/flash-scroll-help.fla

    Thank you so much again you're the best!

    p.s. Please note that the video doesn't seem to switch sides untill the site is actually embedded in an html page on a server. I have been running tomcat on my local machine to reproduce the issue so that I don't have to upload/download the video all the time. I just can't seem to figure out the issue.
  12. #7
  13. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2011
    Location
    Kansas
    Posts
    14
    Rep Power
    0
    Originally Posted by Tann San
    ok, upload it somewhere and post a link.
    Hey I was trying to give you reputation points for being so helpful but for some reason I can't. My user info says I have 10 points to give but when I tried to give you points the drop down box would only display 0.
  14. #8
  15. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2011
    Location
    Kansas
    Posts
    14
    Rep Power
    0
    Tann San,

    Have you had a chance to look at the video for me? Just to let you know I really appreciate your help very much! I have been trying on my own with no success

    Thanks again.
  16. #9
  17. No Profile Picture
    Gotta get to the next screen..
    Devshed Supreme Being (6500+ posts)

    Join Date
    Nov 2003
    Location
    Legion of Dynamic Discord
    Posts
    6,678
    Rep Power
    3165
    Hi, sorry I forgot to check it. Have now though. Only had a quick glance but a line jumped out at me almost straight away in the ActionScript panel of "Layer 6":

    logo_mc._x = Stage.width - 800;

    That's on line #7 then there's this onResize bit below that on lines 12-19. What I think is happening is that the screen is getting resized but the Stage.width value is not getting updated in time. It could be that on refresh you onResize function is not being called. It's hard to say without doing some testing.

    The all out easiest solution is to use a fixed value for the logo position and to not allow the clip to be resized i.e. change line #7 to:

    logo_mc._x = 0;

    Then delete lines 12-19 so there is no onResize event listener.

    Let me know if that is workable, otherwise if the banner is going to get resized all the time then we'll have to work out another solution.
    Quis custodiet ipsos custodes?
  18. #10
  19. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2011
    Location
    Kansas
    Posts
    14
    Rep Power
    0
    Originally Posted by Tann San
    Hi, sorry I forgot to check it. Have now though. Only had a quick glance but a line jumped out at me almost straight away in the ActionScript panel of "Layer 6":

    logo_mc._x = Stage.width - 800;

    That's on line #7 then there's this onResize bit below that on lines 12-19. What I think is happening is that the screen is getting resized but the Stage.width value is not getting updated in time. It could be that on refresh you onResize function is not being called. It's hard to say without doing some testing.

    The all out easiest solution is to use a fixed value for the logo position and to not allow the clip to be resized i.e. change line #7 to:

    logo_mc._x = 0;

    Then delete lines 12-19 so there is no onResize event listener.

    Let me know if that is workable, otherwise if the banner is going to get resized all the time then we'll have to work out another solution.
    Again thank you so much! I will give that a shot when I get back to that office. I will let you know if that works or if we need to figure something else out.

    Thanks again your the best!
  20. #11
  21. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2011
    Location
    Kansas
    Posts
    14
    Rep Power
    0

    Update


    Tann San,

    So, I gave that a shot and it won't work that way. I repositioned the image to where it needed to be and changed the code as indicated however, once the browser is refreshed or the page is resized the image still moves about half an inch or so. If you would please help me find a solution I would be most greatful. I will give you all the reputation points I have if I can only figure out how to award them. I tried once and I didn't work.

    Thank you!!!!!!!!!!!!!!!!!!!!!!!!!!

    Robert
  22. #12
  23. No Profile Picture
    Gotta get to the next screen..
    Devshed Supreme Being (6500+ posts)

    Join Date
    Nov 2003
    Location
    Legion of Dynamic Discord
    Posts
    6,678
    Rep Power
    3165
    If you removed the onResize event handling code as I suggested then the logo should not move when the screen is refreshed.
    Quis custodiet ipsos custodes?
  24. #13
  25. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2011
    Location
    Kansas
    Posts
    14
    Rep Power
    0

    Update


    Tann San,

    I did remove everything and set the variables as you indicated. The problem is that once that is done the logo is no longer on the far right it is some where off-center. I am guessing that this is because of the positioning that was being done on the fly by the listener. So instead of doing:

    logo_mc._x = 0;

    I did

    logo_mc._x = 750; (or whatever made it sit on the right corner. I'm not at that office right now so I don't remember the exact coordinate.)

    The problem with this is that when the page refreshes the logo moves about an inch or so not to mention that when the browser was resized the logo is not visible.

    As you know I am very new to the flash/adobe world so, if you could please help me figure out how to make the image sit on the right corner and move when the page is resized but not refreshed (make the logo always on the far right), or sit on the left side and not move ever I would be forever greatful.

    Just to let you know I really appreciate all of your help and if you ever need any help with anything Java/Android related you can count on me all you have to do is ask.

    Thanks again,

    Robert
  26. #14
  27. No Profile Picture
    Gotta get to the next screen..
    Devshed Supreme Being (6500+ posts)

    Join Date
    Nov 2003
    Location
    Legion of Dynamic Discord
    Posts
    6,678
    Rep Power
    3165
    Right, well I think half the problem is the logo itself. Go inside "logo mc", unlock all the layers and then select all the logo content on the stage. Drag it all so it is aligned to the left hand side of the + axis. So the top right corner of the logo graphics should be to the bottom left of the + symbol. I attached some screenshots to show what I mean.

    Then using the same resizing code as you did before change the two lines:

    logo_mc._x = Stage.width - 800;

    To:

    logo_mc._x = Stage.width;
    Attached Images
    Quis custodiet ipsos custodes?
  28. #15
  29. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2011
    Location
    Kansas
    Posts
    14
    Rep Power
    0

    More Updates


    Tann San,

    I am not sure if I am doing this correctly but I think that I am. Below are the exact steps I performed and there result.

    1. I set logo_mc._x = Stage.width;
    2. I deleted the listener
    3. I selected the entire logo and moved the logo so that it is completely to the left of the x. (What I mean by this is the logo is not ontop of the background picture at all, it is butted up against the background picture to the left of the x.)
    4. Saved the video and exported it to a movie.
    5. Uploaded the video to my server
    6. Uploaded an html file that has the video embedded in it.
    7. Went to the web address that I have set up.

    When I hit the index page to start with the logo is on the right. If I refresh the index page or go to a page other than the index page the logo moves from right to left.

    Thank you, Thank you, Thank you for your help!!!

    Robert

    p.s. note that I am testing this in i.e. because most of the visitors to this site use i.e.




    Originally Posted by Tann San
    Right, well I think half the problem is the logo itself. Go inside "logo mc", unlock all the layers and then select all the logo content on the stage. Drag it all so it is aligned to the left hand side of the + axis. So the top right corner of the logo graphics should be to the bottom left of the + symbol. I attached some screenshots to show what I mean.

    Then using the same resizing code as you did before change the two lines:

    logo_mc._x = Stage.width - 800;

    To:

    logo_mc._x = Stage.width;
Page 1 of 2 12 Last
  • Jump to page:

IMN logo majestic logo threadwatch logo seochat tools logo