#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2010
    Location
    Preston UK
    Posts
    22
    Rep Power
    0

    Problem with Filzilla or iptables on server


    Hi Guys...

    I get an error message when I try to ftp into my web site:

    Error: Failed to retrieve directory listing

    I think that the problem is something to do with my server firewall.
    I am running Centos 5 and vsftpd ftp server.
    If I stop the firewall I get the directory listing.
    With the firewall started I do not get the directory listing.

    Can anybody advise which ports should be allowed in the firewall to get the directory listings.

    Thanks,
  2. #2
  3. Did you steal it?
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    13,959
    Rep Power
    9397
    Is FileZilla using passive mode? Check settings, or look for a PASV command.
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2010
    Location
    Preston UK
    Posts
    22
    Rep Power
    0
    Many thanks for taking the time to try and help me.
    Originally Posted by requinix
    Is FileZilla using passive mode? Check settings, or look for a PASV command.
    I am using Filzilla 3.5.1
    Filezilla is using Passive mode.
    There doesn't appear to be any user settings for passive mode.
    I can't see any PASV command.

    Here is the login returns:
    Response: 331 Please specify the password.
    Command: PASS *****
    Response: 230 Login successful.
    Status: Connected
    Status: Retrieving directory listing...
    Command: PWD
    Response: 257 "/home/ukzone"
    Command: TYPE I
    Response: 200 Switching to Binary mode.
    Command: PASV
    Response: 227 Entering Passive Mode (88,97,199,145,41,103)
    Command: LIST
    Error: Connection timed out
    Error: Failed to retrieve directory listing
    I wonder if the above might help to diagnose the problem.

    Regards,

    John C
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2010
    Location
    Preston UK
    Posts
    22
    Rep Power
    0
    Originally Posted by countrydj
    Many thanks for taking the time to try and help me.

    I am using Filzilla 3.5.1
    Filezilla is using Passive mode.
    There doesn't appear to be any user settings for passive mode.
    I can't see any PASV command.

    Here is the login returns:

    I wonder if the above might help to diagnose the problem.

    Regards,

    John C
    PROBLEM SOLVED !!!!

    Thanks to requinix who asked if Filezilla was in Passive mode, I tried it in ACTIVE mode and it worked.

    Many thanks for the idea...

    Any idea why it doesn't work in PASSIVE mode ???

    John C
  8. #5
  9. Did you steal it?
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    13,959
    Rep Power
    9397

IMN logo majestic logo threadwatch logo seochat tools logo