#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2002
    Posts
    32
    Rep Power
    12

    Question ProFTPD startup error using default script


    Hello,
    I just compiled and maked the latest ProFTPD source. I added the default startup script, $SOURCE_DIR/contrib/dist/rpm/proftpd.init.d, to /etc/rc.d/init.d. I renamed it to proftpd, and created a symbolic link to it in rc3.d (S90proftp). Now, during startup, I noticed it wouldn't start so...I tried starting it manually with the script via ./S90proftp start

    I got the following error:

    Starting proftpd: execvp: No such file or directory

    I checked my system log also, it was the same error message, no more information then above.

    The server WILL start manually via /usr/local/sbin/proftpd, just not with the supplied script.

    Any suggestions?

    Thanks

    P.S. I am running the server standalone and as a non privaleged user.
    Last edited by ultra; August 7th, 2002 at 09:57 PM.
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    190
    No such file or directory - the script is calling a program that is not available.

    look in the script for the line that starts proftpd. bet it has another path than the one you installed it to? it should look like this:

    /usr/sbin/proftpd

    or maybe

    startproc /usr/sbin/proftpd

    correct it. if this is not the problem, post the script here (as attachment, please, not inline) and iŽll have a look at it.
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2002
    Posts
    32
    Rep Power
    12
    Hey,
    Thanks for replying.

    look in the script for the line that starts proftpd. bet it has another path than the one you installed it to?
    I already did that. I changed everything to the proper path. Just for the reference, it was installed to /usr/local/sbin. I also fixed the paths to the lock files.

    I have attached the shell script to this post.

    Thanks for the help
    Attached Files
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    190
    /usr/local/sbin is probably not in your searchpath. replace the line:
    Code:
    daemon proftpd $OPTIONS
    with
    Code:
    daemon /usr/local/sbin/proftpd $OPTIONS
    or add the line
    Code:
    PATH=$PATH:/usr/local/sbin
    before it.

    does it work now?
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2002
    Posts
    32
    Rep Power
    12

    Talking


    Thanks M.Hirsch,
    That did the trick...The thing is, its in my $PATH already, but if it works I dont care.

    Thanks again

IMN logo majestic logo threadwatch logo seochat tools logo