#1
  1. Don't shoot, we're not a tiger
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2006
    Location
    Merry Old England
    Posts
    255
    Rep Power
    60

    Setting up FTP access on Xampp Server


    Hey,
    I recently set up a Xampp server so that I could practice PHP+MySQL more efficiently (as opposed to uploading to an external server everytime I make a change).

    The problem that I'm having with FTP access is that:

    If I type in localhost on the server, it directs me straight to the 'Xampp' folder in the htdocs directory...
    ...this is password protected using .htaccess and .htpasswd...
    ... the FTP server is therefore trying to connect to the htdocs directory but is being redirected to the Xampp directory (which, of course, will not accept the FTP password)...
    Therefore, I get a 'connection failed' message.

    Does anyone know how to stop this redirection? I might be able to cheat my way around it by setting up a directory path, but I'd rather just get it sorted out properly .
    Any help is much appreciated!
    Thanks,
    Liam.
    PS: Xampp comes with the FileZilla FTP server, incase anyone was interested =P.
  2. #2
  3. 'fie' on me, allege-dly
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2003
    Location
    in da kitchen ...
    Posts
    12,889
    Rep Power
    6444
    Liam, did you get this one sorted?
    --Ax
    without exception, there is no rule ...
    Handmade Irish Jewellery
    Targeted Advertising Cookie Optout (TACO) extension for Firefox
    The great thing about Object Oriented code is that it can make small, simple problems look like large, complex ones


    09 F9 11 02
    9D 74 E3 5B
    D8 41 56 C5
    63 56 88 C0
    Some people, when confronted with a problem, think "I know, I'll use regular expressions." Now they have two problems.
    -- Jamie Zawinski
    Detavil - the devil is in the detail, allegedly, and I use the term advisedly, allegedly ... oh, no, wait I did ...
    BIT COINS ANYONE
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2007
    Posts
    1
    Rep Power
    0

    I had same issue


    well right or wrong this is how i did it. I removed the index.html file from the htdocs folder and replaced it with
    the index.html file from my homepage. I also have all the other files from my main homepage sitting in the htdocs folder.
    now when i go to the localhost it is my homepage and the ftp:// takes me to the htdocs folder only. hope this makes a little sense. or maybe i missed the problem all together.
  6. #4
  7. Devshed Beginner (1000 - 1499 posts)

    Join Date
    Jan 2004
    Location
    New Springfield, OH
    Posts
    1,214
    Rep Power
    1469
    The FileZilla FTP Server that comes with XAMPP has a graphic wizard setup...

    Anyway...here's what you're problem was. You never completely set up your FTP user. When you set up a user in FileZilla, you have to select a folder to grant the user access to. If you don't, it just defaults to the program's installation folder which is probably nowhere near where you want to be.

    Click the User button on the toolbar. Select the user you want to edit and make any necessary changes. It's slightly confusing because you have to navigate several tabs to see all of the settings.
    Don't like me? Click it.

    Scripting problems? Windows questions? Ask the Windows Guru!

    Stay up to date with all of my latest content. Follow me on Twitter!

    Help us help you! Post your exact error message with these easy tips!

IMN logo majestic logo threadwatch logo seochat tools logo