A perfectly operational site (html5+css+java script) , as it is ran from my local disk , has been uploaded to the server.
It has not worked online! (as the navigation tabs are clicked the screens are not opened suggesting a problem with js files).
As it is the first time that I host on the server of this company I suspected of some problem on server side (despite it is still static html) and then I uploaded to another web server on which I have space.
It hasnīt worked either.
My 2nd suspicion was something to do with FTP , despite I have never had any problem alike.
I downloaded the files/folders from both servers with the same result : both came in as it is online , not working. I employ an old 32 bits program ACEFTP PRO 3.61.0 (sept 8 2004) to send files.
By lack of options I started to suspect on everything ranging from file corruption during ftp transfer (ASCII vs. BINARY - this made me configure aceftp pro transfer option from auto to binary) to some incompatibility with my new 64 bits hardware.
The next step was to employ Dreamweaver CS6 to do the upload task.
I deleted all files from server and uploaded the site files with Dreamweaver.
The result was again the same on both servers , the site does not work and once again I downloaded the files and tested the site on my local disk : site does not work. Some file probably a JS is corrupted.
Up to now I have never had this problem before what makes me inquire what is going on here ?