#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2001
    Posts
    11
    Rep Power
    0

    Urgent Problem. Having problems with FTP and FreeBSD


    Hello there,

    I'm having problems connecting via FTP to my freebsd box. Comes up with "connection refused"

    Does anyone know how I can troubleshoot this one. I need to get in to the machine to copy some files across.

    cheers,

    Adam
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2001
    Posts
    4
    Rep Power
    0
    1) Check and make sure FTPd is up and running. Check /etc/inetd.conf.
    2) Check TCP Wrappers. The control file is -> /etc/hosts.allow.
    3) Check your firewall ruleset, if any.
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2001
    Posts
    11
    Rep Power
    0

    Thumbs up


    Thanks a heap for that. I uncommented out the bit relating to FTP in the inetd.conf, rebooted and everythings fine now.

    cheers,

    Adam
  6. #4
  7. o0o.o0o
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2001
    Location
    m00n
    Posts
    194
    Rep Power
    102
    You could also start ftpd explicitly on start up in rc.local as an alternative to using inetd.
  8. #5
  9. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2001
    Posts
    11
    Rep Power
    0
    Thanks for your suggestion. As I'm a bit new at FreeBSD/Unix - what's the difference between the two methods ?

    cheers,

    Adam
  10. #6
  11. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2001
    Posts
    4
    Rep Power
    0
    >> what's the difference between the two methods ?

    When running FTPd as a daemon, you can't configure access restriction with TCP Wrappers. It also takes more resource when launching multiple daemons. Unlike proftpd and apache where you can configure those when running out of inetd.
    BTW, I don't trust inetd and I have it completely disabled for all my *BSD boxes. If I have a need to run FTP server, I either run Proftpd standalone or use a inetd replacement -> tcpserver.

    Like I always said, djb (qmail author) makes the most secure software on earth. If there exists a djb software that is intended to be a replacement (except publicfile to replace Apache), follow his advice and just do so. Just to name a few:
    - dnscache to replace BIND cache
    - tinydns+axfrdns to replace BIND authoritative DNS server
    - qmail to replace sendmail
    - tcpserver to replace inetd
    - multilog to replace syslogd

IMN logo majestic logo threadwatch logo seochat tools logo