#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2001
    Location
    entlegen
    Posts
    442
    Rep Power
    14

    how to disable anonymous ftp in redhat 7.1 ???


    how to disable anonymous ftp in redhat 7.1 both internally and externally???

    currently my ftp is on. I do not wish to enable ftp for everyone including anonymous.


    would u please tell me how? I also used ssh- ftp and NAT points to another port.
    regards,

    wish to use AT 89c51 single chip computer to do remote sensing and send the data back from woods to office via nokie 3330 and internet. HOW?
    first I must revise C program thro' example, what's next?
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2001
    Posts
    174
    Rep Power
    19
    /etc/inetd.conf
    ../ftpusers
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2001
    Location
    entlegen
    Posts
    442
    Rep Power
    14
    in /etc/ftpuser, I added "anonymous" and reboot the whole machine and ran wu-ftp to test if "anonymous" can login.

    I do not find inetd.conf by whereis and find stmt.
    regards,

    wish to use AT 89c51 single chip computer to do remote sensing and send the data back from woods to office via nokie 3330 and internet. HOW?
    first I must revise C program thro' example, what's next?
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2000
    Posts
    114
    Rep Power
    15
    Well, on RH 7.1, Bob probably meant /etc/xinetd.conf and to manage ftp access you should use the /etc/ftpaccess file (/etc/ftpusers is deprecated). If you want to disable ftp entirely but continue running other services managed by xinetd, edit the file /etc/xinet.d/wu-ftpd and change 'disable = no' to 'disable = yes'.
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2001
    Location
    entlegen
    Posts
    442
    Rep Power
    14
    I edited the file /etc/xinet.d/wu-ftpd and change 'disable = no' to 'disable = yes'. and it is disable.


    thanks!
    regards,

    wish to use AT 89c51 single chip computer to do remote sensing and send the data back from woods to office via nokie 3330 and internet. HOW?
    first I must revise C program thro' example, what's next?

IMN logo majestic logo threadwatch logo seochat tools logo