Hey guys, I just set up vsftpd on one of my webservers (Ubuntu server 10.10) so a user can access her pages remotely. It's set up in a chrooted mode for this particular user. When I connect (my username), using sftp, it has no problem. It shows me all directories, no permissions issues, etc. However, if I try to connect with her user name in filezilla, I get:
Network error: Software caused connection abort
Could not connect to server

If I try in other clients (such as Dreamweavers SFTP extention), I get other connection errors, however, I can connect just fine using my username. Below are my associated config files, anything that starts with // is a comment describing different things I've tried and how it reacts.

-snippets from vsftpd.conf:

-snippets from vsftpd.nochroot_list:

-snippet from vsftpd.allowed_users:

-shell command:
$ groups herusername:
herusername : sftp

-snippet from sshd_config:
Subsystem sftpd internal-sftp
Match Group sftp
ChrootDirectory %h
X11Forwardin no
AllowTcpForwarding no
ForceCommand internal-sftp
//if I comment out all of that, she has no problem getting access... but then she has access to everything.

-snippet from passwd:
//1002 is the sftp group, as you can imagine. I've tried giving her shell access with bin/bash and bin/sh but to no avail

-shell command:
$ ls -l /www/rspages:
drwxr-xr-- 7 herusername sftp deals
//I previously had it as root:root deals, but I wanted to eliminate the possibility of an error, so I adjusted it to herusername:sftp

Does anyone have an idea of what I'm doing wrong? I wouldn't chroot the user if I didn't have to, but I worry about her connecting on a public computer.. That, or someone might obtain her login information somehow.

Thank you for your time