#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2004
    Posts
    17
    Rep Power
    0

    Question keep getting syntax error code:0 in IE


    Hello,

    on loading the site I'm making, www.squobble.com, Internet Explorer gives me the following error:

    Code:
    Line: 2
    Char: 1
    Error: Syntax error
    Code: 0
    URL: http://www.squobble.com
    The first lines of the code are
    Code:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <HTML>
    <HEAD>
    <LINK rel="stylesheet" type="text/css" name="minimal" href="styles/squarestyle.css">
    <meta http-equiv="content-type" content="text/html;charset=ISO-8859-1">
    
    <title>Squobble</title>
    </HEAD>
    and I can't find out what it is that bothers IE on that supposed line 2. Anyone of you seeing an erro in this code? (or on the website itself)

    thanks
    syturvy
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Location
    Mexico
    Posts
    79
    Rep Power
    15
    I accessed squobble.com with Netscape 7.1 and got the following error:

    Error: syntax error
    Source File: http://www.squobble.com/scripts/urlmanage.js
    Line: 1
    Source Code:
    <TITLE>.:: Page not found ::.</TITLE>

    Netscape is a little more descriptive with Javascript errors, thanks to its javascript console. With Explorer 6.0 I keep getting the error you mention...

    Hope this info is useful...

    Regards,

    Ricardo O.
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2004
    Posts
    17
    Rep Power
    0
    Originally Posted by Rick007
    Hope this info is useful...
    Sure, it works fine now
    Thanks a lot!

    syturvy
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2004
    Posts
    1
    Rep Power
    0
    Can anyone tell me how this was fixed??? I am getting the same error as stated above for about twenty lines in the middle of my page...????
  8. #5
  9. No Profile Picture
    The Forest
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2002
    Posts
    321
    Rep Power
    17
    I doubt this has much to do with anything, but your DOCTYPE is lacking a reference to a resource:

    Code:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    You need to specifiy the location of the DTD file in the DOCTYPE declaration:

    Code:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/1999/REC-html401-19991224/loose.dtd">
    Hope that helps!

    Happy coding!
  10. #6
  11. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2004
    Posts
    17
    Rep Power
    0
    Originally Posted by jswoodsr
    Can anyone tell me how this was fixed??? I am getting the same error as stated above for about twenty lines in the middle of my page...????
    Well, that syntax error shows up for a lot of reasons. In this case, it was because the reference to the JavaScript file wasn't valid, and hence it was quickly solved by correcting that link. But chances are that you get this error for other reasons, in which case you could do as suggested: open the page in Netscape 7.1, or post the code on the forum.

    syturvy

IMN logo majestic logo threadwatch logo seochat tools logo