#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2013
    Posts
    24
    Rep Power
    0

    Playing mp4 video converted with ffmpeg in html5


    I have converted an flv video in mp4 using ffmpeg.but this not playing in html5.it is giving an error
    "No video with supported MIME type found"
    can anyone help ??
  2. #2
  3. Code Monkey V. 0.9
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Mar 2005
    Location
    A Land Down Under
    Posts
    2,136
    Rep Power
    1990
    The supported video format depends entirely on the browser that you're using. As an example, .mp4 won't play in fireFox because they don't include the licencing for that format.

    The way to do proper video in HTML5 is to have three versions of the video file available - MP4, OGG and WebM. Set up these three and you'll have the best chance of having the video play on all platforms.
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2013
    Posts
    24
    Rep Power
    0
    Thanx...The problem is solved by setting up the video in all formats.
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2013
    Posts
    24
    Rep Power
    0
    Hello
    as i have told, i converted the flv video to mp4 and ogg. and playing it in html5.
    i am facing a problem that the sound is by default off and disabled.
    i have searched out about it on internet but could not get any solution..can u help me in this??
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2009
    Posts
    113
    Rep Power
    16
    Originally Posted by Preetvision
    Hello
    as i have told, i converted the flv video to mp4 and ogg. and playing it in html5.
    i am facing a problem that the sound is by default off and disabled.
    i have searched out about it on internet but could not get any solution..can u help me in this??
    I had this issue and it turned out i was using the wrong audio codec. My MP4 works with the AAC(faac) audio codec. For your OGV i believe you're supposed to use the Vorbis codec but i could be wrong on that one.

    Hope that helps.
  10. #6
  11. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2013
    Posts
    24
    Rep Power
    0
    Hello dsfx
    i tried the conversion using codecs as..

    exec("ffmpeg -i uploads/$file -acodec libfaac uploads/output.mp4 ");
    exec("ffmpeg -i uploads/$file -acodec libvorbis uploads/output.ogg ");

    but did'nt work with the sound problem.
    is there any mistake in the above commands???

IMN logo majestic logo threadwatch logo seochat tools logo