#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2003
    Location
    Toronto
    Posts
    166
    Rep Power
    11

    Upload form Browse button not working in IE7 IE8


    Hi

    I came across an issue when trying ti UPLOAD FILES in IE8/IE7.

    The generated "Browse" button is blank; about 10px wide; does not contain the "Browse" text and does not function.

    The code works in all other browsers except for IE7 & IE8 (I am using IE Tester to validate)

    Here is the page link to the page: http://www.webforward.ca/prototypes/...eb/step3.shtml
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2011
    Location
    Sydney Australia
    Posts
    186
    Rep Power
    84
    Works for me using IE8.
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2010
    Posts
    18
    Rep Power
    0
    I checked on an old pc I have with IE7 and the text 'Browse' is showing on the button.
  6. #4
  7. CSS & JS/DOM Adept
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jul 2004
    Location
    USA (verifiably)
    Posts
    20,127
    Rep Power
    4304
    It looks fine in IE8 and IE7 on WinXP here. I suggest you use virtual machines to test with instead of IE Tester.
    Spreading knowledge, one newbie at a time.

    Check out my blog. | Learn CSS. | PHP includes | X/HTML Validator | CSS validator | Common CSS Mistakes | Common JS Mistakes

    Remember people spend most of their time on other people's sites (so don't violate web design conventions).

IMN logo majestic logo threadwatch logo seochat tools logo