#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2013
    Posts
    50
    Rep Power
    2

    How do I validate?


    Okay, very silly question, I guess... But I ran my site through the validator at w3 and it came back with a list of errors. (I didn't write the code, I just need to fix it.)

    For example:

    Error Line 19, Column 6: An head start tag seen but an element of the same type was already open.

    Okay, so my question is, where do I find Line 19 Column 6? My FTP program doesn't number lines, but even if it did, I can't seem to find where it's talking about... And what is the column?

    So, my underlying question has to do with FINDING the invalid code...

    Any thoughts would be appreciated!
  2. #2
  3. Transforming Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    14,191
    Rep Power
    9398
    Do a View Source in your browser of the page you're checking. It'll probably include line numbers.
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2013
    Posts
    50
    Rep Power
    2
    Originally Posted by requinix
    Do a View Source in your browser of the page you're checking. It'll probably include line numbers.
    So, what does the Column mean?

    Also, in this case, the error doesn't make sense. It says the head tag isn't closed, but it is... And there's only one open head and one close head...
  6. #4
  7. Old Fart
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2012
    Location
    Chicago
    Posts
    108
    Rep Power
    4
    Column is the character position in the line.

    Code:
    For example: the "l" is in column 10.
             ^
             |
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2013
    Posts
    50
    Rep Power
    2
    Originally Posted by richpri
    Column is the character position in the line.

    Code:
    For example: the "l" is in column 10.
             ^
             |
    So, any thoughts on how to fix this one then? It doesn't make sense...

    Code:
    <!DOCTYPE html> <!--[if IE 6]> <html id="ie6" dir="ltr" lang="en-US"> <![endif]--> <!--[if IE 7]> <html id="ie7" dir="ltr" lang="en-US"> <![endif]--> <!--[if IE 8]> <html id="ie8" dir="ltr" lang="en-US"> <![endif]--> <!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!--> <html dir="ltr" lang="en-US"> <!--<![endif]-->  <!-- MOBILE SITE REDIRECT --> <script src="http://static.dudamobile.com/DM_redirect.js" type="text/javascript"></script> <script type="text/javascript">DM_redirect("http://mobile.dudamobile.com/site/cleantelligent");</script>  <head> <base href="" />  <meta charset="UTF-8" /> <meta name="viewport" content="width=device-width" /> <title>The Leading Janitorial Software for Cleaning Inspections: Janitorial Software by CleanTelligent</title>  <link rel="stylesheet" type="text/css" media="all" href="/wp-content/themes/cleantelligent/style.css" />  <!--[if lt IE 9]> <script src="/wp-content/themes/twentyeleven/js/html5.js" type="text/javascript"></script> <![endif]--> <!--[if lte IE 9]> <link rel="stylesheet" type="text/css" media="all" href="/wp-content/themes/cleantelligent/ie.css" /> <![endif]-->   <link rel='stylesheet' id='frm-forms0-css'  href='/wp-content/uploads/formidable/css/formidablepro.css?ver=1.06.05' type='text/css' media='all' /> <script type='text/javascript' src='/wp-includes/js/jquery/jquery.js?ver=1.7.2'></script> <script type='text/javascript' src='/wp-includes/js/comment-reply.js?ver=3.4.2'></script>     <link rel='next' title='Privacy Statement' href='/privacy-statement' />   <!-- All in One SEO Pack 1.6.15.2 by Michael Torbert of Semper Fi Web Design[395,402] --> <meta name="description" content="CleanTelligent Janitorial Software - Online inspection, communication, and tracking CMMS. Janitorial software for the cleaning and janitorial industry." /> <link rel="canonical" href="/" /> <!-- /all in one seo pack --> <script src="/wp-content/themes/cleantelligent/js/jquery.cycle.all.js" type="text/javascript"></script> <script src="/wp-content/themes/cleantelligent/js/jquery-ui-1.8.19.custom.min.js" type="text/javascript"></script> <link href='http://fonts.googleapis.com/css?family=Cabin' rel='stylesheet' type='text/css'> </head>
  10. #6
  11. Old Fart
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2012
    Location
    Chicago
    Posts
    108
    Rep Power
    4
    Try putting the <head> before the first <script>
  12. #7
  13. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2013
    Posts
    50
    Rep Power
    2
    Try putting the head before the first script
    Welp, that did it! Thanks a boatload guys!
    This has been by far the most helpful forum so far.

IMN logo majestic logo threadwatch logo seochat tools logo