#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2003
    Posts
    18
    Rep Power
    0

    web based browser emulator written completely in html -> help needed


    ok. im working on an html coded browser emulator. the reason for doing this is I play flight simulator 2004 which has a simple tweak out where the ingame kneeboard can be used as a web browser. but it is just the page, nothing else. no navigation controls or address bar. thus limits me to only being able to access websites that i have linked to in that page. i am trying to make this html browser emulator to fix that. so far im using a frameset system. the top frame is coded as below:

    <html>

    <head>
    <meta name="GENERATOR" content="Microsoft FrontPage 6.0">
    <meta name="ProgId" content="FrontPage.Editor.Document">
    <meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
    <title>New Page 1</title>
    </head>

    <body>

    <center>
    <table border="0" width="44%" id="table1" style="border-collapse: collapse" height="19">
    <tr>
    <td width="253" align="center"><input type="button" onclick="document.frame_main.history.go(-1)" value="Back">
    <input type="button" onclick="document.frame_main.history.go(1)" value="Forward">
    <input type="button" onclick="" value="Stop">
    <input type="button" onclick="document.main.refresh()" value="Refresh">
    </td>
    <td align="center"><form name="address_bar"><input type="text" name="url" value="">
    <input type="button" onclick="document.main.location=this.address_bar.url" value="Submit"></form></td>
    </tr>
    </table>
    </center>
    </body>

    </html>
    but its giving me a javascript error on all butons when I try to use them. nothing happens whatsoever when I click them. if someone can help me debug them, id be happy.

    also, is there a code I can use in the main frame to keep all links contained in that frame and keep them from loading in new windows?
    Last edited by Vchat20; November 4th, 2003 at 10:08 PM.
  2. #2
  3. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2003
    Posts
    18
    Rep Power
    0
    ok. through help by someone on another board, i changed the button codes from having document to parent and it has helped. the forward and back buttons work, but refresh and go still give errors.
  4. #3
  5. nx
    Devshed Novice (500 - 999 posts)

    Join Date
    Aug 2003
    Location
    USA
    Posts
    626
    Rep Power
    0
    well..since youre using frames....it wouldnt be document.main.location.....itd be document.main.src=....
    and also, give your form target="main"...that is...if the frames name is main

IMN logo majestic logo threadwatch logo seochat tools logo