#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2013
    Posts
    2
    Rep Power
    0

    IP camera streaming and playback issue using Widows media player embedded code


    I have H-series ip camera, i want to play recorded video in SD card of that ip camera in "Windows Media player", I have embedded WMP code in my application, I am able to play it but when i load my application page it is asking me two time user authentication that don't want, i am passing user authentication in src(underline and bold) as shown in following code, how to solve this issue pleas help me out i am pasting my WMP code as follows

    <object id="MediaPlayer" width="300" height="300" type="video/x-ms-asf">
    <param name="FileName"value="http://admin:123456@192.168.1.4:8088/sd/20131210/record000/P131210_102036_103038.avi">
    <param name="autostart" value="true">
    <param name="ShowControls" value="true">
    <param name="ShowStatusBar" value="false">
    <param name="ShowDisplay" value="false">
    <embed type="application/x-mplayer2" src="http://admin:123456@192.168.1.4:8088/sd/20131210/record000/P131210_102036_103038.avi"
    width="192" height="190" ShowControls="1" ShowStatusBar="0" ShowDisplay="0" autostart="0" />
    </object>
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Oct 2009
    Location
    Nebraska, USA
    Posts
    875
    Rep Power
    275
    if you are trying to access this over the internet, and not just thru the local LAN, you will need to use the "external" IP address in the link [if its a static IP], or a domainname [if its a dynamic IP]. then, make sure you have the port 8088 forwarded correctly.
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2013
    Posts
    2
    Rep Power
    0
    Originally Posted by DonR
    if you are trying to access this over the internet, and not just thru the local LAN, you will need to use the "external" IP address in the link [if its a static IP], or a domainname [if its a dynamic IP]. then, make sure you have the port 8088 forwarded correctly.

    sorry but i know all these things, i want know how to play video from that camera, videos are recorded in the SD card of that camera and i am trying to play in "windows media player", it well play if i give this src "http://username : password@ip(local/external) : port/sd/path/filenme.avi" but two time it will ask me camera authentication in pop up that i don't want.. above src was working in vlc but now vlc not supporting so m trying in WMP
    please help me to solve this issue...

    thank you

IMN logo majestic logo threadwatch logo seochat tools logo