#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2003
    Posts
    53
    Rep Power
    12

    Apache and IIS on win2k problem


    I have Apache 2.0.46 (win32) running on a Windows2000 PC. I also have IIS running on the PC.

    When I start up the PC, Apache starts automatically. Thus if I want to use IIS I need to stop Apache, then start up IIS. I want to set things up to allow IIS to run as default on bootup, instead of Apache.

    I've had a look on the web and the settings for Apache and cannot find how to change this setting.

    Any ideas?

    Thank you

    Jim
    -----
    http://www.jimpix.co.uk
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2003
    Location
    Paris, France
    Posts
    375
    Rep Power
    12
    Why did you not use service control panel to change apache service seeting ?
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2003
    Posts
    42
    Rep Power
    12
    If you run default installations of both IIS and Apache on the same machine then they will both try to use port 80 so only one service will start. You need to edit your httpd.conf file to change Apache's port number to the http alternative port 8080. Find the line that says "Listen 80" or ("Listen xxx.xxx.xxx.xxx:80") and change it to "Listen 8080" (or "Listen xxx.xxx.xxx.xxx:8080") then restart Apache and go to http://localhost:8080 in your browser to see the Apache site, http://localhost will be the IIS site.

    Alternatively, you could change the IIS default port to 8080 which would have pretty much the same effect.
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2004
    Posts
    35
    Rep Power
    11
    It may be also worthwhile to ensure that apache is not setup to startup at logon (in addition to teedee's advice.) Remove it from your startup items, and if its a service disable or set to manual rather than automatic start.

    Zipikaye!!

IMN logo majestic logo threadwatch logo seochat tools logo