#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2004
    Posts
    2
    Rep Power
    0

    Unhappy Asking for authentication on index.shtml file?!?


    Hello All,
    IIS5, Windows 2000 Advanced, FP Extensions 2002.
    My index page has an include, so it is index.shtml. My main website is open to the public with anonymous/integrated windows security. Anyone can get to it without a password or anything. After a reboot, my index.shtml page is asking for a username/password when anyone tries to browse to it. I got around this by renaming index.shtml to index.html. This works, but of course the include isn't there. I've checked the default document, server authentication(still anonymous/integrated) and NTFS rights on the index.shtml file but I can't seem to open it up without being prompted for authtication. I pulled an older copy of my index.shtml off of tape and replaced the current one and recalculated the web, but no luck. I also removed the FP2002 extensions and extended the web with the 2000 extensions that come with IIS5. Is there something that needs to be done so my server can display .shtml files normally/with no authentication? I don't know if the FP Extensions enable the ability to use includes, but could reinstalling FP Extensions 2002 fix the problem?
    Thanks!!
    Tyler
  2. #2
  3. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,439
    Rep Power
    4539
    If the web server is using the anonymous web user account, normally the IUSR_computername account, make sure that user has permissions to the main index file and any includes, and any files called by any includes like image files, etc.

    If I understand you, you have both and index.html and index.shtml file in the same folder. You might try renaming the include file just in case there is some conflict caused by the same filename.
    ======
    Doug G
    ======
    Bartender to Rene Descartes "have another beer?" Descartes: "I think not" and he vanished.
    --Alfred Bester
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2004
    Posts
    2
    Rep Power
    0
    I'm using index2.html currently, it comes up fine with full public access. With the web security set to anonymous/integrated windows, I get prompted when I try to view the index.shtml file. But when I set it to just anonymous, I don't even get prompted on the index.shtml file, it goes directly to 401.3 authentication failed. I've reinstalled the FP Extensions and recalculated the web numerous times. All signs point to some kind of permission problem, but I've pretty much given the IUSR account full Read/Execute rights to the web root folder, including the "/inc" include folder.
    The index document has 2 Frontpage includes and one Server Side Include. The Server Side Include is the one that's not displaying when the page is viewed(after you have to authenticate to it.)The include file is located in the /inc folder. Is there something tricky with include files(*.shtml) that IIS
    has problems with? I've looked at the app configuration settings in IIS Manager, support for *.shtm and *.shtml files is there...using ssinc.dll like normal. I wonder if upgrading to Service Pack 4 will replace something that might be corrupted?
    Last edited by tyler_777; March 17th, 2004 at 01:11 PM.
  6. #4
  7. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,439
    Rep Power
    4539
    I don't use shtml files but I'm not aware of any problems with IIS and shtml files.

    My bet is still a permissions problem somewhere, where the IUSR_computername user account doesn't have permission to something, a file, a registry node, a temp folder.
    ======
    Doug G
    ======
    Bartender to Rene Descartes "have another beer?" Descartes: "I think not" and he vanished.
    --Alfred Bester

IMN logo majestic logo threadwatch logo seochat tools logo