#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2003
    Posts
    63
    Rep Power
    11

    Can't bring up localstart.asp or iisstart.asp anymore


    I just installed Windows XP Pro on my new laptop and was fiddling with getting IIS to be 'seen' from outside by forwarding IP/port to my internal IP address assigned by my wireless access point. I got that working, which included adding "Everyone" to the virtual directory that created. Anyway, all thay works now.

    However, in the process of getting things to work, I somehow caused localstart.asp and iisstart.asp in the Default Web Site to no longer be accessible on the browser. If I type: http://localhost/localstart.asp, I get an HTTP 500.100 error. If I type: http://myIPAddress/localstart.asp, the URL would be redirected to http://myIPAddress/iisstart.asp as expected, but would show and "Under construction" error page. I know localstart.asp and iisstart.asp used to work before. Can someone tell me how to restore that functiionality?
  2. #2
  3. No Profile Picture
    Stumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,409
    Rep Power
    4538
    Possibly the "fiddling" broke whatever method localstart.asp uses to prevent it from running unless you are on the local computer.

    Since it's new, you could I suppose uninstall IIS, nuke the wwwroot folder, then reinstall & see if localstart comes back to life.
  4. #3
  5. No Profile Picture
    Banned
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2003
    Posts
    15
    Rep Power
    0
    IIS has an excellent control panel where you can specify default docs, allow executables,scripts etc. What is listed under default document? It is not recommended to run wwwroot with "everyone group". IIS has an IUSR an account used to access the webfolder. Do a search on "locking down IIS".
  6. #4
  7. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Posts
    4
    Rep Power
    0
    I spent all day fixing that, and getting firebirdsql to work... have yet to do that part.

    Make sure security is set to low under the home directory tab, for the folder (or site), and then click "configure" in the same tab, on the new window, click the Options tab, then uncheck "Enable Parent Paths"... I don't know why this worked, nothing helped me, I just did it and it worked.

IMN logo majestic logo threadwatch logo seochat tools logo