#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2003
    Posts
    39
    Rep Power
    12

    need help with iss 6 and hostnames


    Hello. I have an account with www.no-ip.com and have a hostname called myname.no-ip.com

    Those of you who arent familiar with no-ip, it is simply a service that redirects subdomain names to dynamic IP addresses. Anyways, I turned on an option for WildCards, which means that anytime a user types a word and a period in front of my site address, it will always take them to myname.no-ip.com

    Example: If a user were to open a browser and go to blah.myname.no-ip.com, it will take you to the same place as myname.no-ip.com

    >I configured IIS to check for the hostname and take the user to different parts of my site
    >I configured my main site to respond to the hostname of myname.no-ip.com and it works
    >I configured 2 other sites in IIS to respond to site1.myname.no-ip.com and site2.myname.no-ip.com and neither work....both take me back to myname.no-ip.com

    Can anyone offer info. as to why this isnt working?


    Specs:
    -windows 2003 server enterprise edition
    -iis 6

    Any help would be appreciated. thanks
  2. #2
  3. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,441
    Rep Power
    4539
    Sorry, I'm not up on IIS6. Maybe there is something on www.iisfaq.com
  4. #3
  5. Retired Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jan 2004
    Location
    London, UK
    Posts
    6,669
    Rep Power
    147
    Hi,

    When someone types in site1.mydomain.no-ip.com doesn't it automatically get forwarded to mydomain.no-ip.com, because you have turned Wildcards on?

    Don't you want to turn off Wildcards so that the IIS server can look at the different host names.

    I'm not familiar with no-ip.com, but if I understand your post correctly, surely wildcards prevent you from setting up different websites.

    HTH,

    Edwin
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2003
    Posts
    39
    Rep Power
    12
    Okay, I turnd off wildcards. Do i Have to register my somethings.mysite.com names somewhere? Or can I use them as I please?
  8. #5
  9. Retired Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jan 2004
    Location
    London, UK
    Posts
    6,669
    Rep Power
    147
    Firstly, I think I would try accessing subdomain.myname.no-ip.com and see if with wildcards off, you can access your website. I would have guessed that subdomain.myname.no-ip.com would forward to your dynamic IP address and then IIS would be able to direct it to the correct site, depending upon the domain.

    If this doesn't work, is there an option in the web admin for no-ip.com to create a new subdomain which also re-directs to the same dynamic Ip address?

    Without ever using no-ip.com I'm not sure, but try these two things first and let me know how you get on.
  10. #6
  11. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2003
    Posts
    39
    Rep Power
    12
    Is there anyway to test the site from the server? the server is my own computer and to get to my site, I always have to go to http://localhost and going to mysite.no-ip.com only works from other computers. If not, I will have to test it later today.
  12. #7
  13. Retired Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jan 2004
    Location
    London, UK
    Posts
    6,669
    Rep Power
    147
    What happens if you just type in subdomain.myname.no-ip.com into your own browser inside the network?
  14. #8
  15. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2003
    Posts
    39
    Rep Power
    12
    i get a dns error. the same error occurs when i type myname.no-ip.com

    i thought this was normal though...is it supposed to bring my page up?
  16. #9
  17. Retired Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jan 2004
    Location
    London, UK
    Posts
    6,669
    Rep Power
    147
    I would have thought that when you typed in myname.no-ip.com your DNS query should be automatically forwarded to your ISP's DNS servers. These should then be able to translate the domain name into the external Ip address of your firewall/router.

    When you make the changes on no-ip.com does it say the changes are instant? They may not be, and you may need to wait for your ISP's DNS servers to update (this could take a day or two). However, I should have thought that you should definitely been able to access myname.no-ip.com from your internal network. Can you try it at the same time from somewhere externally to see if that works? See if the problem is only internal or if it is external as well.
  18. #10
  19. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2003
    Posts
    39
    Rep Power
    12
    I wont be able to test it externally until later. No-ip.com says it takes a few mins to update. I have tested it in the past and it always works externally, but never internally.
  20. #11
  21. Retired Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jan 2004
    Location
    London, UK
    Posts
    6,669
    Rep Power
    147
    Does no-ip.com give any information about hosting subdomains?

    If they don't, why don't you try emailing them.

    I use ZoneEdit http://www.zoneedit.com and they definitely allow you to configure subdomains and have support for dynamic ips.

    Have a look on their website and see what you think. They provide free DNS hosting for up to 5 different domains.
  22. #12
  23. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2004
    Posts
    4
    Rep Power
    0

    Having the same problem


    I have a static IP and configured BIND 9.x on my Windows XP Pro and it's resolving wonderfully. The thing is, and I'm guessing it's the same problem, all subdomains actually point to the same IP, that's my case. Everything's working fine, but subdomains in IIS 5.1. Be it a WildCard or a specified subdomain that points to the same IP of my main page hosted on IIS 5.1. What I can't get setup is that subdomains get redirected to different sites on the same IP, or a different port as well.

    Any ideas??
  24. #13
  25. Retired Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jan 2004
    Location
    London, UK
    Posts
    6,669
    Rep Power
    147
    I have a similar thing which I have resolved OK. I have a static IP and several subdomains all point to the same IP. To have different websites for the same IP but different subdomains I used host header values. So, in IIS I create a new website for each subdomain name and this works fine. However, you're using XP Pro with IIS 5.1 and you can only have one website. This really limits you - if you want to host lots of websites consider Windows Server 2000 or 2003.

IMN logo majestic logo threadwatch logo seochat tools logo