#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2005
    Posts
    4
    Rep Power
    0

    Exclamation IIS 5.1 XP Pro "No web site is configured at this address" error


    I am finding myself unable to configure my website to run on my computer. Fresh format of XP Pro, IIS 5.1 installed.
    http://localhost/ gives me the 404 error, I turned ff friendly errors through my internet options and now receive a "No web site is configured at this address" error...

    IIS state is "running" but status is blank.

    anonymous login is enabled.
    Inetpub/wwwroot folder is shared, my "home.html" is enabled as the default document, XP firewall is off, I have browsed soooo many forums and it seems that people get their sites working fine yet all replies and threads seem to indicate that their http://localhost is working just fine... and that happens to be my hurdle.

    I followed every step that I previously used with IIS and win XP (pre-sp2) and wonder also if something has changed (IIS version 5.1 or sp2) that requires me to do something in addition to to what I have done before I formatted and reinstalled the SP2 version of XP.

    I know there are a billion little settings to tweak and I will of course expound on my setting sf asked, but I thought maybe someone out there might have a suggestion or comment based on what I've said thus far.

    Any help would be greatly appreciated.
  2. #2
  3. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2005
    Posts
    4
    Rep Power
    0

    Smile More technical info


    For anyone wondering, here are the technical in depth settings. Y= checked on, N= not checked.

    IIS installed with Common files, Documentation,FTP Service, IIS Snap In, World Wide Web Service
    (with printers Virtual Dir, Scripts virtual dir, WWW Service)

    Website status: Rnning, Host header name: blank, IP Addy: 70.26.129.237 port: 80

    WEB SITE
    HTTP keep alive enabled : Y
    Enable loggging: Y

    ISAP FILTERS: blank

    HOME DIRECTORY:
    content should come from: A Directory on this computer :Y
    Local path: c:\inetpub\wwwroot (wich I have shared through explorer: share folder on network:Y, Allow users to change files: Y)

    Script source acccess: N
    Read: Y
    Write: N
    Dir browsing: N
    Log Visits: Y
    Index resource: Y

    application setting:
    Application name: Default Application
    Execute Permissions: Scripts Only
    Aplication protection: Medium(pooled)

    DOCUMENTS:
    enable default docimentss: Y
    (I have set this to home.html and moved that name to the top of the list. I have copied home.html (and all oter website files) to the inetpub/wwwroot directory)
    enable document folder: N

    HTTP HEADERS:
    enable content expiration: N

    DIRECTORY SECURITY:
    ANONYMOUS ACCESS & AUTHENTICATION CONTROL: (EDIT)
    anonymous access: Y
    User name: UBERSTATION\IUSR_UBERSTATION (UBERSTATION being my computer name)
    allow IIS to control password: Y
    basic authentication: N
    Integrated Windows Authentication : N
  4. #3
  5. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,489
    Rep Power
    4540
    Have you checked the XP firewall (or any other firewall software)? Maybe it's blocking port 80.
    ======
    Doug G
    ======
    Bartender to Rene Descartes "have another beer?" Descartes: "I think not" and he vanished.
    --Alfred Bester
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2005
    Posts
    4
    Rep Power
    0
    Thanks for the response Doug!
    My XPfirewall is OFF, but I manually opened port 80 through it just in case Still no go.
    I have no other firewall software installed, and am rnning Norton Antivirus 2005 and MSN Antispyware software.. I have disabled both of these in case they were causing problems, but get the same result.

    What next?
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2005
    Posts
    4
    Rep Power
    0
    ok, after some playing I got localhost to work...
    It seems the only way it will work is when I assign my IP address to "All Unassigned" in the IIS website tab.

    Thats great and all, but now I can't get anyone to view my page when they type http://<my ip address>

    ???
  10. #6
  11. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2008
    Posts
    1
    Rep Power
    0

    localhost


    This post details the problem I am currently having with classic asp.

    My VB.Net is fine but classic fails.
    IIS 5.1
    XP Pro

    What changes were made to get localhost to work?
  12. #7
  13. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,489
    Rep Power
    4540
    Originally Posted by Dognose77
    This post details the problem I am currently having with classic asp.

    My VB.Net is fine but classic fails.
    IIS 5.1
    XP Pro

    What changes were made to get localhost to work?
    Did you read the post? This topic is over 3 years old, it's very likely the OP isn't around to answer you. You'll have better luck by starting your own question topic instead of resurrecting ancient topics.
    ======
    Doug G
    ======
    Bartender to Rene Descartes "have another beer?" Descartes: "I think not" and he vanished.
    --Alfred Bester

IMN logo majestic logo threadwatch logo seochat tools logo