#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2008
    Posts
    120
    Rep Power
    8

    IIS 7/PHP Intranet Site - Windows Authentication Not Working As Intended


    Under IIS 6 you could configure integrated Windows Authentication by going to the Directory Security or File Security tab to select the Windows Integrated Authentication check box. You could then uncheck Anonymous Authentication to get IIS to display information related to the user.

    For example:
    Code:
    <?php
    $user = $_SERVER['LOGON_USER'];
    echo "$user";
    ?>
    Would display DOMAIN\Username of the logged on user.

    Under IIS 7 when I try to repeat this behavior it does not work as it did under IIS 6.

    I have enabled Windows Authentication within II 7 and disabled Anonymous and Basic Authentication within IIS. Doing so prompts the user for a username and password. If the user inputs their username (or DOMIAN\username) and password it still fails.

    Not sure why something so simple under IIS 6 seems to be so overly complicated in IIS 7. Could I be missing a step?

    Thank you for reading.
  2. #2
  3. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2013
    Posts
    2
    Rep Power
    0
    Does the application pool identity have access to your intranet website?

    Can you get to the site with just anonymous Authentication?

IMN logo majestic logo threadwatch logo seochat tools logo