#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2011
    Posts
    3
    Rep Power
    0

    Nooooobie: Can't get localhost or 127.1.1.0 to work


    In Windows 7 Ultimate - installed IIS 7, all admin privileges are set.............but when I type 'localhost' or '127.0.0.1', (even if it's 'localhost\index.htm [the .htm file I created]), I'm taken to some third party search web site........ Interestingly, I have Windows 2003 Server running in VirtualBox VM and that same operation works fine.

    I have tried EVERYTHING with no luck whatsoever. Does anyone have any ideas?

    Many thanks in advance.
  2. #2
  3. Did you steal it?
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    13,961
    Rep Power
    9397
    A "good" search site? Or something that you might expect from a malware installation? Check your hosts file (system32\drivers\etc\hosts) that it doesn't have any entries in it. As in
    Code:
    # Copyright (c) 1993-2009 Microsoft Corp.
    #
    # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
    #
    # This file contains the mappings of IP addresses to host names. Each
    # entry should be kept on an individual line. The IP address should
    # be placed in the first column followed by the corresponding host name.
    # The IP address and the host name should be separated by at least one
    # space.
    #
    # Additionally, comments (such as these) may be inserted on individual
    # lines or following the machine name denoted by a '#' symbol.
    #
    # For example:
    #
    #      102.54.94.97     rhino.acme.com          # source server
    #       38.25.63.10     x.acme.com              # x client host
    
    # localhost name resolution is handled within DNS itself.
    #	127.0.0.1       localhost
    #	::1             localhost
    and that's all.

    I assume you've made sure that IIS and a website is running, right?
  4. #3
  5. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,424
    Rep Power
    4539
    Try typing the full url, i.e., http://localhost or http://127.0.0.1 This should eliminate your browser from trying an automatic search, if you still end up at an unknown search site try stopping the IIS service, then try the same localhost url again and see what happens.
    ======
    Doug G
    ======
    The man who doesn't read good books has no advantage over the man who can't read them.
    --Mark Twain
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2011
    Posts
    3
    Rep Power
    0
    Originally Posted by Doug G
    Try typing the full url, i.e., This should eliminate your browser from trying an automatic search, if you still end up at an unknown search site try stopping the IIS service, then try the same localhost url again and see what happens.
    Thanks everyone. Please pardon the newbie question - this is not my background. I have been duly designated as the "IT guy" for our small workgroup here, so have to deal with this. (Ugggghh, I'm dreading setting up Exchange that I have to do....)

    Anyway, the fully qualified URL worked (sort of, see below....) now, this is almost embarrasing, but there are NO 'hosts' files on this computer. I did a global search....(Program Files and Program Files (X86) is where the 'Windows NT' folders live, which is where I would assume this folder would reside, but it's not.)

    Also, when I do type in the fully qualified URL, I get a 'HTTP Error 401.3 - Unauthorized' error. Somehow I don't have an access to my wwwroot folder? (This is where I place my website folders with the index filethat I am trying to access.) I am an Administrator on this computer and I checked my User Access levels and they are global 'Read/Write". I even set "Sharing' of this folder on. Any ideas?

    Again, thanks very much for your help.
  8. #5
  9. Did you steal it?
    Devshed Supreme Being (6500+ posts)

    Join Date
    Mar 2007
    Location
    Washington, USA
    Posts
    13,961
    Rep Power
    9397
    The hosts file is at
    Code:
    C:\Windows\system32\drivers\etc\hosts
  10. #6
  11. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2011
    Posts
    3
    Rep Power
    0
    Originally Posted by requinix
    The hosts file is at
    Code:
    C:\Windows\system32\drivers\etc\hosts
    Thanks!! My hosts file looks identical to the one you posted in your original reply. I'll figure it out one way or another....thanks again.
  12. #7
  13. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,424
    Rep Power
    4539
    I think IIS by default prevents access to files in the root of the web. Better is to make a virtual directory for your site, or some google may find what you need to change to allow file access in the web root.
    ======
    Doug G
    ======
    The man who doesn't read good books has no advantage over the man who can't read them.
    --Mark Twain
  14. #8
  15. Who set my Title?
    Devshed Novice (500 - 999 posts)

    Join Date
    Jun 2004
    Posts
    716
    Rep Power
    258
    I am an Administrator on this computer and I checked my User Access levels and they are global 'Read/Write". I even set "Sharing' of this folder on. Any ideas?
    Your being Administrator should not have any effect on the display of the page. The permissions have to be set in IIS like Doug G pointed and not on the file system. Also - no point in sharing the folder.
    Nobody is perfect. I am Nobody.
  16. #9
  17. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2011
    Posts
    1
    Rep Power
    0
    The same problem

IMN logo majestic logo threadwatch logo seochat tools logo