#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2004
    Posts
    204
    Rep Power
    0

    permissions for "C:\Inetpub\wwwroot"


    what permission do set for this folder so that the internet users can see the webpages??
  2. #2
  3. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,449
    Rep Power
    4539
    Normally the IUSR_computername user account is used by IIS for anonymous web surfers. Make sure this account has permissions to any web folders you want to allow unauthenticated browsing. Also your IIS needs to be set to allow anonymous users.
    ======
    Doug G
    ======
    Bartender to Rene Descartes "have another beer?" Descartes: "I think not" and he vanished.
    --Alfred Bester
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Intermediate (1500 - 1999 posts)

    Join Date
    Jan 2004
    Location
    Budapest
    Posts
    1,703
    Rep Power
    67

    Doug, SOS!


    Doug, I hope you can help me with this issue. If I open up my computer's Windows Explorer, right click on the Inetpub directory and choose properties, the little box for read only is checked. If I uncheck the box and hit apply, it ask me if I want the change for only the inetpub folder, or all folders and files within. I choose the latter. Then it goes through its thing of Applying Attributes. This takes a minute or so. Then, if I go back to the Inetpub and again click for properties, the "read only" back is again checked. What I am trying to do is to set up a web on my local host and write to a MS Access database. But everytime I try to do this, I get this error:

    Code:
    Error Type:
    ADODB.Recordset (0x800A0CB3)
    Current Recordset does not support updating. This may be a limitation of the provider, or of the selected locktype.
    /permissions/test.asp, line 13
    
    Browser Type:
    Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322) 
    
    Page:
    GET /permissions/test.asp
    Can you offer any suggestions?
    Today the world, tomorrow the universe...
  6. #4
  7. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,449
    Rep Power
    4539
    If you're using XP make sure "simple file sharing" is not enabled.
    ======
    Doug G
    ======
    Bartender to Rene Descartes "have another beer?" Descartes: "I think not" and he vanished.
    --Alfred Bester
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Intermediate (1500 - 1999 posts)

    Join Date
    Jan 2004
    Location
    Budapest
    Posts
    1,703
    Rep Power
    67

    Success


    Originally Posted by Doug G
    If you're using XP make sure "simple file sharing" is not enabled.

    Doug, I did what you said and initially it didn't work. I restarted and tried again, but no success. Then I started to "poke" around a bit. I went to the mmc and checked permissions, they were ok. I then checked the asp code and adlock was set to read only, I changed it to pessimistic but still no success. Then i went right to the file in Windows Explorer. Right clicked and went to properties. From the I chose security and there were several users (?) I set full control for all of them. Now it works... I also went to the Inetpub directory itself and did the same for the whole directory...
    Today the world, tomorrow the universe...
  10. #6
  11. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,449
    Rep Power
    4539
    THe usual user account for IIS is IUSR_computername
    ======
    Doug G
    ======
    Bartender to Rene Descartes "have another beer?" Descartes: "I think not" and he vanished.
    --Alfred Bester

IMN logo majestic logo threadwatch logo seochat tools logo