#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2001
    Posts
    14
    Rep Power
    0

    PHP Configuration With IIS 5.1 and XP


    I have installed PHP 4.3.3 with IIS 5.1 and configured IIS 5.1 so that when a .php file is called it runs php.exe. When I call a .php file in the browser an instance of php.exe can be seen triggered in the Task Manager process window. The script never finishes and I end up with a timeout message.

    "CGI Timeout
    The specified CGI application exceeded the allowed time for processing. The server has deleted the process"

    The script I am trying is just <?php phpinfo();?>

    I did wonder if the issue is a permissions one. php.exe seems to be running as IUSR_<my pc name>

    I have modified the permissions on the folders that contain both php.exe and the .php scripts. But this has made no difference


    Any ideas ?


    Thanks


    Justin
  2. #2
  3. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2003
    Posts
    4
    Rep Power
    0
    In IIS ISAPI filter, add the php ISAPI filter and try it.
    You should be able to find the filter in the php directory.

    I haven't tested the perfomance specs but heard it's easier and scripts run faster at lower load that way.
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2003
    Posts
    81
    Rep Power
    12
    Seems like your php.ini isn't configured properly. Are you using ISAPI or Fast CGI ??

IMN logo majestic logo threadwatch logo seochat tools logo