#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2013
    Posts
    3
    Rep Power
    0

    Using CURL on IIS 6.0 - 501 Error


    Hi,

    I have installed IIS 6.0 on a Windows 2003 R2 Box and am now trying to PUT a file there.

    Here is the verbose response.

    C:\>C:\curl.exe -verbose --upload-file c:\A.log --url http://[IISServerName]/[FolderName]/ --N
    TLM
    * About to connect() to [IISServerName] port 80 (#0)
    * Trying IP.ADD.RES.S...
    * connected
    * Connected to [IISServerName] (IP.ADD.RES.S) port 80 (#0)
    > PUT /work/scripts/[....]/A.log HTTP/1.1
    > User-Agent: curl/7.25.0 (i386-pc-win32) libcurl/7.25.0 OpenSSL/0.9.8u zlib/1.2
    .6 libssh2/1.4.0
    > Host: [IISServerName]
    > Accept: */*
    > Referer: rbose
    > Content-Length: 1273
    > Expect: 100-continue
    >
    < HTTP/1.1 501 Not Implemented
    < Content-Length: 0
    < Server: Microsoft-IIS/6.0
    < Date: Mon, 04 Mar 2013 14:33:39 GMT
    * HTTP error before end of send, stop sending
    <
    * Closing connection #0

    I believe I have given all permissions(Read/Write/Execute).
    Now the same command works fine in a XP box with IIS 5.0 installed and I am able to upload the file

    Any help to solve this will be appreciated..
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Oct 2009
    Location
    Nebraska, USA
    Posts
    873
    Rep Power
    275
    have you tried changing the compatibility mode of your curl.exe file? to XP mode or try "run as administrator" on your curl.exe file.

    I'm not an IIS person, so, those suggestions may not even be related to your issue.
    Last edited by DonR; March 4th, 2013 at 12:53 PM.
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2013
    Posts
    3
    Rep Power
    0
    Originally Posted by DonR
    have you tried changing the compatibility mode of your curl.exe file? to XP mode or try "run as administrator" on your curl.exe file.

    I'm not an IIS person, so, those suggestions may not even be related to your issue.
    Hey, Thanks for your reply.
    So the system from where I have installed curl.exe is a windows xp box and the remote system is a win2k3 r2 box.
    So, I am running the command from the command prompt at the source.
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2013
    Posts
    3
    Rep Power
    0

    Thumbs up


    Originally Posted by sachintewari
    Hey, Thanks for your reply.
    So the system from where I have installed curl.exe is a windows xp box and the remote system is a win2k3 r2 box.
    So, I am running the command from the command prompt at the source.
    So I did some searching and I got what I needed to get this up and running.

    Open Web services extension below the default website folder and Enable WebDAV

    "Web Distributed Authoring and Versioning (WebDAV) is an extension of the Hypertext Transfer Protocol (HTTP) that facilitates collaboration between users in editing and managing documents and files stored on World Wide Web servers."

IMN logo majestic logo threadwatch logo seochat tools logo