#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2009
    Posts
    9
    Rep Power
    0

    Website not showing up in IIS 7


    Hello,

    I just setup a new website in IIS 7, but it's not showing up. When I click under "Browse Web Site" (the link is "Browse www_cisweb_com on *:80 (http)", it gives me a page that I didn't create. (the banner says "Cisweb.com what you need, when you need it" with a list of search categories in the body).

    I set the site name to "cisweb.com", set the physical path to my wwwroot folder, set my application pool to defaultAppPool (though I've tried all other application pools), set my default documents to index.html and LoginForm.aspx (in that order, with both file names existing in wwwroot), and setup one binding (hostname: www_cisweb_com, port: 80, IP address: *).

    UPDATE: I tried creating a new binding: cisweb on *:80 (http). Now it's doing something different. It's giving me the error message: HTTP Error 401.3 - Unauthorized. You do not have permission to view this directory or page because of the access control list (ACL) configuration or encryption settings for this resource on the Web server. Error Code: 0x80070005.

    Problem solved: I shared the wwwroot folder with Everyone.
  2. #2
  3. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2012
    Posts
    17
    Rep Power
    0
    Hi,

    No need to shared wwwroot with everyone as its a security risk.
    Its important that web site IUSR have read permissions on web root so as to be able to access it.
    Looking at the error message, it seems to be a permission issue

IMN logo majestic logo threadwatch logo seochat tools logo