#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2003
    Posts
    4
    Rep Power
    0

    different user in my IIS


    I've created a Virtual Web Site on my own machine. When I run a Web page, it creates a Excel report that puts on the network drive. I someone else is is running it, from their machine but calling page from my machine, it doesn't create any files. How can I go around this?
  2. #2
  3. No Profile Picture
    Stumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,409
    Rep Power
    4538
    Post some more information on the problem.

    Probably there is a permissions issue.
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2003
    Posts
    4
    Rep Power
    0
    That was also my thought, but I'm not sure where to change this permissions.
    Again about the problem: I host a Web app on my computer. Web app creates a Excel file when you click a button. If anyone else from the network acces this app, they get error message if they try clicking on that button, saying: "Microsoft Excel cannot access the file '\\"ip address"\WhatIf\Reports'. There are several possible reasons: The file name or path name does not exist. The file you're trying to open is being used by another program. Close the document in the other program, and try again. The name of the workbook you're trying to save is the same as the name of another document that is read-only. Try saving the workbook with a different name. "
    When I run the same app, I don't get that error message. I have <identity impersonate="true" /> in my web.config file and IIS is set to Windows authentification (I changed this because in the begginign even I couldn't write those files). What else should I change?
  6. #4
  7. No Profile Picture
    Stumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,409
    Rep Power
    4538
    It appears you're running IIS6, I'm not familiar with IIS6 permissions. Hopefully someone more familiar with permission settings will hop in.
  8. #5
  9. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2003
    Posts
    4
    Rep Power
    0
    Actually, it is IIS5.

IMN logo majestic logo threadwatch logo seochat tools logo