#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2004
    Posts
    4
    Rep Power
    0

    Trouble with IIS 5.1 serving asp files


    Hi,

    I'm running XP Pro Sp1 with IIS 5.1 and MSDE. I have both running and plan to test a small website. When accessing my local default website within IIS I can accesssing any html page created with FrontPage without a problem but I cannot display asp or aspx pages correctly. After creating a test.aspx page and placing it in the wwwroot directory and I get when I access the page with IE is the text of the page and not the asp version of it.

    Any ideas on what might be causing this or what I'm doing wrong?

    Thanks,
    Bob
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Location
    Arlington, VA
    Posts
    191
    Rep Power
    11
    Check for the Framework version. Make sure you have 1.1 installed. Also check your IIS config - allows to execute asp and aspx pages.
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2004
    Posts
    4
    Rep Power
    0
    Thanks for the response.

    I'm not too familiar with the permissions settings but I'm assuming that this is done by accessing Default Web site Properties, then the Home Directory tab, and then Execute Permissions at the bottom. I have this set to Scripts only. Is this correct?

    Thanks,
    Bob
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2004
    Posts
    2
    Rep Power
    0
    The problem isn't executing scripts -- it's probably that there are no ISAPI mappings for ASP.NET pages setup.

    The best and easiest way to do this is with a command-line utility that is installed with the .Net framework.

    Drop to a command-line on your workstation and go to the .Net framework installation directory, which is:

    C:\windows\microsoft.net\framework\v1.1.4322

    if you have version 1.1 of the framework installed. If you have version 1.0 of the framework, the folder would be

    C:\windows\microsoft.net\framework\v1.0.3705

    Anyway, once you're in this folder at a command prompt type this command and hit Enter:

    aspnet_regiis -i

    This will make sure all the websites on your machine are configured to support .aspx pages.

    Best,
    Aaron Gibbs
    S3 Host
    http://www.s3host.com
    Serious hosting for Serious Microsoft Developers
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2004
    Posts
    4
    Rep Power
    0

    Question


    Thanks for the repley Aaron.

    I tried what you suggested but I'm still not getting anything here. Here is the replay of what I did so you can see it.

    C:\Documents and Settings\Bob>cd C:\windows\microsoft.net\framework\v1.1.4322

    C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322>aspnet_regiis -i
    Start installing ASP.NET (1.1.4322.0).
    Finished installing ASP.NET (1.1.4322.0).

    C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322>

    After this I rebooted and retried my page getting the same text display of the test.aspx web page I created. Here is the text of the page I created for this.

    <%@ Page Language="VB" %>
    <html>
    <head>
    <title>ASP.NET Test</title>
    </head>

    <body>
    <center>
    <form action="test.aspx" method="post">
    <% Dim I As Integer
    For I = 0 to 7 %>
    <font size="<%=I%>">Welcome to ASP.NET</font><br>
    <% Next %>
    </form>
    </center>
    </body>
    </html>

    If I go external to my PC I can open other ASP pages without a problem so it's not something in IE that's causing this.

    Any other suggestions?

    Thanks again,
    Bob
  10. #6
  11. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2004
    Posts
    4
    Rep Power
    0
    Addition - I just tried something else here which is interesting. If [on my local PC] I enter http://desktop/ I get the http://desktop/localstart.asp webpage telling me that IIS is running, etc. It also tells me that users from other machines will get the "under construction" webpage. So I went to another PC on my little network and entered http://desktop/iisstart.asp and I do get an "under construction" page. Then I went back to the IIS help and found an example of an asp page, did a cut and paste, then tested it from PC2. This came back with the intended result. So not knowing that much about asp page formats I'm concluding that the sample text to use was incorrect or some reason. If anyone sees anything obvious point it out to me so I can avoid this in the future.

    Thanks for all the help!
    Bob

IMN logo majestic logo threadwatch logo seochat tools logo