#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2004
    Posts
    1
    Rep Power
    0

    IIS won't work with asp, HTTP 403.1 error


    Hi, I am very new to this IIS stuff. I just learned about asp pages and wanted to try it out. I installed IIS on my XP pro machine and I canít seem to get it to work. I know its something simple most likely, but I am clueless. I can view .htm files when I type http://localhost/somthing.htm in the browser address bar, but not .asp files. Tried the MS help sections and they told me to basically just go to add/remove windows components, install IIS and then test it by typing http://localhost/iisstart.asp, which is a asp page in the wwwroot folder on my C: drive. And well I get that

    HTTP 403.1 Forbidden: Execute Access Forbidden
    Internet Information Services

    Judging by the error I would guess that the settings somewhere are prohibiting me from executing this page? Is that right? I copied a basic .htm file into that DIR and got a different error that talked about not being able to read the file. I figured out how to allow me to read it and got that working. But I canít seem to figure out how to allow me to execute this asp page.

    Any help would be greatly appreciated, thank you
    David.
  2. #2
  3. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,453
    Rep Power
    4539
    Open the IIS Management Console, navigate to your web's virtual directory and make sure execute permissions are there.

    If you weren't an administrator user when you installed IIS, uninstall IIS, log in as administrator, and reinstall.
    ======
    Doug G
    ======
    Bartender to Rene Descartes "have another beer?" Descartes: "I think not" and he vanished.
    --Alfred Bester

IMN logo majestic logo threadwatch logo seochat tools logo