#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2010
    Posts
    11
    Rep Power
    0

    Help! LoadLibraryEx on ISAPI filter "C:\Windows\System32\inetsrv\sspifilt.dll" fail


    Hey, I've only just started looking at IIS for the purpose of using it with Shibboleth and I'm having a problem with the sspfilit.dll and getting the
    Error 500 when I go to localhost. I've explained some of the background information and tried to supply as much relevant information as I could to help.

    Background Information:

    •I recently upgraded from Windows XP to Windows 7.
    •I currently have ALL of IIS installed on this computer, so if I go into "Turn Windows Featurs on or off" in my Control Panel -> Programs menu there is a tick in the "Internet Information Services" box
    •Inside here: Control Panel\System and Security\Administrative Tools
    there is: Internet Information Services (IIS) 6.0 Manager and Internet Information Services (IIS) Manager
    •IIS does work when I type localhost into my browser because I get the IIS7 picture. (This is prior to my addition of filter sspifilt.dll)
    •Permission the the inetpub folder (C:\inetpub) I've set to Administrators with Full control with this being applied to all its subfolders and files and I am the Administrator.
    •Permissions on the inetsrv folder (C:\Windows\System32\inetsrv) I've also set to Administrators with Full control
    •I do have Apache Server 2.2 on my computer but the service is stopped
    The reason why I'm trying to use IIS is for use with Shibboleth, refer to link below

    https : // spaces. internet2.edu / display / SHIB2 / NativeSPWindowsIIS6Installer

    Excerpt from the link:

    Add the filter using the Internet Services Manager console. Right click on the "Web Sites" icon on the left, and bring up the Properties dialog. On the "ISAPI Filters" tab, add a new filter called Shibboleth and specify the libexec\isapi_shib.dll library. The priority should be High, and once the filter is loaded, make sure it appears in the list below the sspifilt entry.

    Issue:

    I added the isapi_ship.dll successfully in ISAP filters and IIS still worked fine. When I read the above instructions however I noticed that I did NOT
    have an sspifilt entry. I did not currently have the sspifilt.dll on my computer. So I downloaded the sspiflt.dll from the internet and I placed it in the following directory.

    C:\Windows\System32\inetsrv\sspifilt.dll

    After doing this I then went to the ISAPI filters feature and added this new filter with the "Add" action button on the right-side pane.

    Filter Name: sspifilt
    Executable: C:\Windows\System32\inetsrv\sspifilt.dll

    After doing this I then restarted IIS with the following command in command prompt: iisreset /noforce

    and I got the message that Internet Services had successfully restarted. However when I then went to "localhost" in my browser

    I got the following Error:

    Server Error in Application "DEFAULT WEB SITE"
    Error Summary

    HTTP Error 500.0 - Internal Server Error
    Calling LoadLibraryEx on ISAPI filter "C:\Windows\System32\inetsrv\sspifilt.dll" failed
    Detailed Error Information

    Module IIS Web Core
    Notification Unknown
    Handler StaticFile
    Error Code 0x8007007f

    Requested URL http://localhost:80/
    Physical Path C:\inetpub\wwwroot
    Logon Method Not yet determined
    Logon User Not yet determined



    I don't know if this means anything but on the web browser tab it says IIS 7.5 Detailed Error - 500.0 Internal Server Error http://localhost/
    Not sure where IIS 7.5 comes from.

    As I said previous I'm completely new to using IIS but I've spent the last few days trying to figure this problem out, and googling all over the place with no success. I really need to get this up and running with Shibboleth so I appreciate any help you can give me.

    Thanks heaps.
  2. #2
  3. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,445
    Rep Power
    4539
    I have no definitive answer, sorry. Did you upgrade to win7 from xp home? If so maybe some leftover from xp home is blocking part of IIS, or another guess, I think there are some missing IIS features in some versions of Windows 7. With XP IIS was not supported in xp home but included in xp pro, and I think it's more of a sliding scale with win7, there is IIS but limited in the home versions. The MS website should answer that for you.

    Check your file settings, in XP you wanted to turn off 'simple file sharing' for IIS to allow full use of ACL's. With simple file sharing on you would never see the security tab on a file or folder properties, and couldn't adjust permissions by user.

    Otherwise check the windows event logs and review the isapi installation steps. I've never used IIS on Win7 it may be very different from the XP version I'm used to.
    ======
    Doug G
    ======
    Bartender to Rene Descartes "have another beer?" Descartes: "I think not" and he vanished.
    --Alfred Bester

IMN logo majestic logo threadwatch logo seochat tools logo