#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2012
    Posts
    1
    Rep Power
    0

    Problem testing website on iis


    hi i created a simple website on asp.net and i tested it and it works fine on visual studio but when i try to test it on iis it does not work it returns an error
    I'm testing it on my laptop and i have the iis that is installed in window 7


    Server Error in '/cse' Application.
    Configuration Error
    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive.

    Source Error:

    Line 15: </connectionStrings>
    Line 16: <system.web>
    Line 17: <compilation debug="true" strict="false" explicit="true" targetFramework="4.0" />
    Line 18:
    Line 19: <authentication mode="Forms">


    Source File: C:\Users\jb\try\web.config Line: 17

    looks like the problem is that my web config is set to net 4 and the iis application pool is set to 2 so i tried to change the application pool to 4 but it didn't help and it seems the page is still running on because on the bottom of the error it says

    Version Information: Microsoft .NET Framework Version:2.0.50727.5420; ASP.NET Version:2.0.50727.5420

    so maybe there is a different way to change the net

    i also tried to change the config file to net 2 but it also failed to work

    any ideas help?
  2. #2
  3. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,439
    Rep Power
    4539
    I don't have any suggestions, sorry. Often googling for the exact error message turns up help from others who have had similar problems.
    ======
    Doug G
    ======
    Bartender to Rene Descartes "have another beer?" Descartes: "I think not" and he vanished.
    --Alfred Bester
  4. #3
  5. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2009
    Posts
    61
    Rep Power
    6
    Originally Posted by jcgldr
    hi i created a simple website on asp.net and i tested it and it works fine on visual studio but when i try to test it on iis it does not work it returns an error
    I'm testing it on my laptop and i have the iis that is installed in window 7


    Server Error in '/cse' Application.
    Configuration Error
    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive.

    Source Error:

    Line 15: </connectionStrings>
    Line 16: <system.web>
    Line 17: <compilation debug="true" strict="false" explicit="true" targetFramework="4.0" />
    Line 18:
    Line 19: <authentication mode="Forms">


    Source File: C:\Users\jb\try\web.config Line: 17

    looks like the problem is that my web config is set to net 4 and the iis application pool is set to 2 so i tried to change the application pool to 4 but it didn't help and it seems the page is still running on because on the bottom of the error it says

    Version Information: Microsoft .NET Framework Version:2.0.50727.5420; ASP.NET Version:2.0.50727.5420

    so maybe there is a different way to change the net

    i also tried to change the config file to net 2 but it also failed to work

    any ideas help?
    It seems that you havent configured .net 4 properly. Please reinstall it again. If you see an error message, your site should be working on .net 4 version.

IMN logo majestic logo threadwatch logo seochat tools logo