#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2002
    Posts
    259
    Rep Power
    13

    Apache + JServ Problems


    Hello,

    First off, this is the software I'm using:

    - Windows 2000
    - Apache 1.3
    - Tomcat 3.2
    - JServ 1.1

    So far, Tomcat runs fine by itself. However, but when I fire up Apache with JServ it says I have an error in the "tomcat-apache.conf" file. The Apache error message reads:

    Syntax error on line 2. Invalid command "ApJservManual", syntax error or defined by a module not included in the server configuration"

    Well I know for sure there isn't a syntax error, because I've never touched this conf file! Any ideas?
  2. #2
  3. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2002
    Location
    Rochester, NY
    Posts
    0
    Rep Power
    0

    Angry I have this same problem! HELP!


    I'm having the same problem. I'm following the tutorial on this site, and this is where I'm stuck... I don't know why it is SOOO HARD to set up an Apache or IIS + Tomcat environment. I've been struggling for weeks, I get close, but something undocumented always happens!

    If anyone can help PLEASE!!!!!!

    Dower
  4. #3
  5. No Profile Picture
    Moderator =(8^(|)
    Devshed Intermediate (1500 - 1999 posts)

    Join Date
    Feb 2002
    Location
    Sacramento, CA
    Posts
    1,710
    Rep Power
    14
    I don't know about that problem, but if you're in a hurry just skip the Apache part. Tomcat works fine as a webserver, at least for development purposes.
  6. #4
  7. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2002
    Location
    Rochester, NY
    Posts
    0
    Rep Power
    0

    Angry Finally figured it out


    Man, what a pain. I finally figured it out!

    In the "Slapping Together a JSP Development Environment" tutorial it said to put a LoadModule command in the httpd.conf file. But this is unnecessary. The tomcat-apache.conf file in the tomcat/conf folder already has this LoadModule directive. This duplication was causing the error! When it was taken out, it worked fine!

    As an FYI, if anyone wants to do the MySQL part of that tutorial, the connector has changed hands, and the code no longer works. It took me a bit to figure the problem out, but the connector is now here:

    http://www.mysql.com/products/connector-j/index.html

    The .Jar file is now named differenly, and class is now called "com.mysql.jdbc.Driver".

    Dower

IMN logo majestic logo threadwatch logo seochat tools logo