#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2012
    Posts
    7
    Rep Power
    0

    Java will not run


    Problem: I cannot get Java console or control panel to run. The details are all in a thread on the "PCHelpForum" dot com - whose URL I am not allowed to post! - search for "Java - Not working at all (2)" or my username hrdubwd.

    I'll not repeat everything here - long story.

    Any suggestions as to how this can be fixed?

    Thanks,

    BWD
  2. #2
  3. Contributing User
    Devshed Expert (3500 - 3999 posts)

    Join Date
    Aug 2010
    Location
    Eastern Florida
    Posts
    3,713
    Rep Power
    348
    What version of java do you have installed?
    What OS are you on?
    Java does not have a console. It reads and writes to the OSs console.

    Please copy and paste here the contents of the command prompt console showing what happens when you try to execute the java command.

    To copy the contents of the command prompt window on MS windows:
    Click on Icon in upper left corner
    Select Edit
    Select 'Select All' - The selection will show
    Click in upper left again
    Select Edit and click 'Copy'

    Paste here.
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2012
    Posts
    7
    Rep Power
    0
    All the details are in the forum thread indicated.
    Console: as may be, but nothing happens when I click that menu item for the system tray icon. Anyway, cpl does not open.

    "Please copy and paste here the contents of the command prompt console showing what happens when you try to execute the java command."
    - on a different machine, so cannot at the moment provide this, if what you mean is run "java" at a command prompt.

    Thanks,

    BWD
  6. #4
  7. Contributing User
    Devshed Expert (3500 - 3999 posts)

    Join Date
    Aug 2010
    Location
    Eastern Florida
    Posts
    3,713
    Rep Power
    348
    What OS are you on?
    What happens if you open a command prompt console and enter: java -version?

    What is "cpl"?
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2012
    Posts
    7
    Rep Power
    0
    XP Pro sp3
    Correct response.
    control panel item
  10. #6
  11. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2012
    Posts
    2
    Rep Power
    0
    You probably need to add java.exe to your path. I haven't used Windows XP in years, so I would suggest looking up how to modify system variables. It's under System -> Advanced Properties, I think.
  12. #7
  13. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2012
    Posts
    7
    Rep Power
    0
    Originally Posted by RuntimeVerif
    You probably need to add java.exe to your path.
    That is not present in the path on another machine where the CP works properly. Notice that java.exe does run - it just does not complete. This was documented on the other forum.
  14. #8
  15. Contributing User
    Devshed Expert (3500 - 3999 posts)

    Join Date
    Aug 2010
    Location
    Eastern Florida
    Posts
    3,713
    Rep Power
    348
    What does "not complete" mean?
  16. #9
  17. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2012
    Posts
    7
    Rep Power
    0
    Simply that it starts, runs for a while, then stops, without ever showing a window (tracked using Process Monitor, Process Explorer). It has then disabled the 'installed' check as detailed elsewhere until the process has been killed.
  18. #10
  19. Contributing User
    Devshed Expert (3500 - 3999 posts)

    Join Date
    Aug 2010
    Location
    Eastern Florida
    Posts
    3,713
    Rep Power
    348
    Does the java.exe program do that with all class files you try to execute?
  20. #11
  21. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2012
    Posts
    7
    Rep Power
    0
    As I have said elsewhere, many examples seem to run without problems, but I am stuck with the inability now to run the cpl, console and update. I could live without the one installation test, I suppose, but I take its failure as indicative of a deeper problem that ought to be fixed. The fact that all the uninstall - install - cleanup and other routines that I have tried in various ways multiple times make no difference is weird, esp. since the 7u3 install reports that it is already there (and I know it is not) - so what vestige remains that nobody knows about?
  22. #12
  23. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2012
    Posts
    7
    Rep Power
    0
    After a lot more effort, and too long a story to recount here now, I have managed to clean out most if not all traces (JavaRa 2.1 + manual searching), but 7u13 wil not install: "Wizard Interrupted" - no error message.

    There are logs, I have now found, the key one of which is this:

    jusched.log
    -------------------
    Mon Feb 04 20:13:15 2013
    :: No Old AU Version found

    Mon Feb 04 20:13:36 2013
    :: <strong>Save Country Code KW after GetCountry() </strong>
    Mon Feb 04 20:15:13 2013
    :: Could not get MSIStatusError registry value.
    Mon Feb 04 20:15:13 2013
    :: Could not get MSIStatusExtendedError registry value.
    Mon Feb 04 20:15:13 2013
    :: GetMSIStatus() failed. Return Code: 2, ErrorCode: 183
    Mon Feb 04 20:15:13 2013
    <strong>:: GetUpdatedJreMetrics() - MachineCount registry value exists </strong>

    Mon Feb 04 20:15:13 2013
    :: GetUpdatedJreMetrics() - MachineCounted: YY, InstallAttempts: 2, UpdateCount: 1

    Mon Feb 04 20:15:20 2013
    :: Ping Values: $sc_xml_ver#1.0$reportsuiteid#suninstallstat$visitorid#51d6dd51-0feca10f$prop21#51d6dd51-0feca10f$prop20#XXXXXX$pagename#ic$evar24#0$evar25#0$evar2#1.7.0_13-b20$evar3#XX$evar15#1.7.0_13-b20$evar40#-1$evar26#-99$evar27#2.1.9.0$evar28#XX$evar4#i586$evar5#i586$evar6#winxp-sp3$evar7#joff$evar8#KW$events#event6,event7$evar17#2$evar18#YY$evar19#1$evar29#0$products#;j
    ---------------------------

    1. Where is the country code? This is NOT the MS locale/country/language settings.

    2. Where are the JRE Metrics hidden? This is after cleaning, and a manual pickover.


    Likewise we have in

    java_install_sp.log
    ----------------------------------------------
    GetSponsorOffer(), started 2/3/2013 at 18:22
    ----------------------------------------------
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    -- SetPreferenceList -- The preference order is: SP12;SP14;SP16;SP11;
    -- ImportSponsorsOffered -- No sponsorsoffered key detected
    -- ImportSponsorsOffered -- sponsors offered:
    -- CheckDefaultCriteria -- Begin internal CCT for SP11
    -- IsCountrySupported -- Begin Country validation for SP11
    -- IsCountrySupported -- Detected Country: KW
    -- IsCountrySupported -- The Country is not supported
    -- IsCountrySupported -- Supported Countries: US;
    -- SetIS2Ping -- Successfully set: ,;s11|-131;;;event7=1
    -- IsOSSupported -- Begin OS validation for SP11
    -- IsOSSupported -- OS is supported
    -- IsBrowserSupported -- Begin browser validation for SP11
    -- IsBrowserSupported -- Detected default browser: 0
    -- IsBrowserSupported -- Default browser is supported
    -- IsLocaleSupported -- Begin Locale validation for SP11
    -- IsLocaleSupported -- Detected locale: 1033
    -- IsLocaleSupported -- The Locale is supported
    -- CheckDefaultCriteria -- Begin internal CCT for SP12
    -- IsCountrySupported -- Begin Country validation for SP12
    -- IsCountrySupported -- Detected Country: KW
    -- IsCountrySupported -- The Country is not supported
    -- IsCountrySupported -- Supported Countries: US;UK;AU;CA;DK;FI;FR;DE;NL;NO;SG;SE;CH;AT;BE;IL;IT;PL;ES;BR;CZ;HK;IN;MX;PT;AR;CL;EE;HU;RO;SI;TR;
    -- SetIS2Ping -- Successfully set: ,;s12|-131;;;event7=1
    -- IsOSSupported -- Begin OS validation for SP12
    -- IsOSSupported -- OS is supported (OS validation for SP12 turned OFF)
    -- IsBrowserSupported -- Begin browser validation for SP12
    -- IsBrowserSupported -- Detected default browser: 0
    -- IsBrowserSupported -- Default browser is not supported
    -- IsBrowserSupported -- Required browser: 1
    -- IsLocaleSupported -- Begin Locale validation for SP12
    -- IsLocaleSupported -- Detected locale: 1033
    -- IsLocaleSupported -- The Locale is supported (Locale validation for SP12 turned OFF)
    -- CheckDefaultCriteria -- Begin internal CCT for SP14
    -- IsCountrySupported -- Begin Country validation for SP14
    -- IsCountrySupported -- Detected Country: KW
    -- IsCountrySupported -- The Country is not supported
    -- IsCountrySupported -- Supported Countries: US;UK;AU;CA;DK;FI;FR;DE;NL;NO;SG;SE;CH;AT;BE;IL;IT;PL;ES;BR;CZ;HK;IN;MX;PT;AR;CL;EE;HU;RO;SI;TR;
    -- SetIS2Ping -- Successfully set: ,;s14|-131;;;event7=1
    -- IsOSSupported -- Begin OS validation for SP14
    -- IsOSSupported -- OS is supported (OS validation for SP14 turned OFF)
    -- IsBrowserSupported -- Begin browser validation for SP14
    -- IsBrowserSupported -- Detected default browser: 0
    -- IsBrowserSupported -- Default browser is not supported
    -- IsBrowserSupported -- Required browser: 2
    -- IsLocaleSupported -- Begin Locale validation for SP14
    -- IsLocaleSupported -- Detected locale: 1033
    -- IsLocaleSupported -- The Locale is supported (Locale validation for SP14 turned OFF)
    -- CheckDefaultCriteria -- Begin internal CCT for SP16
    -- IsCountrySupported -- Begin Country validation for SP16
    -- IsCountrySupported -- Detected Country: KW
    -- IsCountrySupported -- The Country is not supported
    -- IsCountrySupported -- Supported Countries: US;UK;AU;CA;DK;FI;FR;DE;NL;NO;SG;SE;CH;AT;BE;IL;IT;PL;ES;BR;CZ;HK;IN;MX;PT;AR;CL;EE;HU;RO;SI;TR;
    -- SetIS2Ping -- Successfully set: ,;s16|-131;;;event7=1
    -- IsOSSupported -- Begin OS validation for SP16
    -- IsOSSupported -- OS is supported (OS validation for SP16 turned OFF)
    -- IsBrowserSupported -- Begin browser validation for SP16
    -- IsBrowserSupported -- Detected default browser: 0
    -- IsBrowserSupported -- Default browser is not supported
    -- IsBrowserSupported -- Required browser: 3
    -- IsLocaleSupported -- Begin Locale validation for SP16
    -- IsLocaleSupported -- Detected locale: 1033
    -- IsLocaleSupported -- The Locale is supported (Locale validation for SP16 turned OFF)
    -- DetermineSponsor -- begin
    -- DetermineSponsor -- The PreferenceOrder is: SP12;SP14;SP16;SP11;
    -- DetermineSponsor -- The SponsorsOfferable are:
    -- DetermineSponsor -- SponsorsOfferableNotAlreadyOffered are:
    -- DetermineSponsor -- NO sponsors found that have not already been offered, walking through SponsorsOfferable to find a sponsor that WAS already offered. SponsorsOfferableSave is: , szPreferenceOrderSave is: SP12;SP14;SP16;SP11;
    -- DetermineSponsor -- NO sponsor found: setting key for Empty Slots
    ----------------

    - where the problems seem to be related to country, sponsor (???) and browser (!! Firefox 18.0.1)

    The stupid thing is that I have no trouble with my laptop and office machine, all here in Kuwait, and all with essentially the same setup.

    Any bright ideas?

    Thanks,

    BWD

IMN logo majestic logo threadwatch logo seochat tools logo