#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2003
    Location
    France
    Posts
    3
    Rep Power
    0

    Unhappy servlet installation: problem with files location


    Hi,

    I'm having problems with installation of a file manager servlet

    http://www.rozina.com/downloads/servlets/fmanager.htm

    My environment is :

    - Windows XP (not my fault)
    - jakarta-tomcat-5
    - j2sdk1.4.0_02

    so i've downloaded the FileManager.class from the above site
    i've created this directory webapps/ROOT/FileManager
    structure of the directory:
    >>FileManager
    {
    >>WEB-INF
    {
    - web.xml
    >>classes
    {
    Filemanager.class
    }
    }
    -fmconf.txt
    }

    the web.xml file: (just for information->not the right syntax)
    -web-app
    -servlet
    - servlet name : FileManager
    - servlet class : FileManager
    - param-name : config
    - param-value : /FileManager/fmconf.txt

    (fmconf.txt is a configuration file for the servlet)

    ok, then i start the server i write this url:

    http://localhost:8080/FileManager/servlet/FileManager

    but i receive the page -> resource not found!

    If you see an error or something i've forgotten, please help me!!

    Thanx!!
  2. #2
  3. No Profile Picture
    Clueless llama
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Feb 2001
    Location
    Lincoln, NE. USA
    Posts
    2,353
    Rep Power
    117
    If you want to have a web app called FileManager, you need to put it in a directory parallel to the ROOT app, not in it. Deciphering your directory structure was a little difficult, but you should have something like this:
    webapps/ROOT
    webapps/FileManager
    webapps/FileManager/WEB-INF
    webapps/FileManager/WEB-INF/web.xml
    webapps/FileManager/WEB-INF/classes/FileManager.class
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2003
    Location
    France
    Posts
    3
    Rep Power
    0
    thanx for replying

    and sorry for the directory structure
    but i've done exactly what you've said before
    and it hadn't worked!!
    maybe i'm missing some server configuration points

    i've always got the same message telling me the resource is not disponible ?/!
  6. #4
  7. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2003
    Location
    France
    Posts
    3
    Rep Power
    0
    maybe u can try this directory and tell me if that works
    in your container
    Attached Files

IMN logo majestic logo threadwatch logo seochat tools logo