1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2002
    Rep Power

    Apache 2 Not Serving index.jsp On URL Request (Error 302?)


    Day 3 now of total ball aching hair pulling frustration caused by Apache 2.

    All I want is a relaxing day at work, being able to develop my nice little JSP/Servlet web apps without the hassle of Apache 2 for one.

    So...I have installed Apache 2. Harmless and lovely when working on it's own. Tomcat 4 is not the issue. This is the good part...all configured and fine when working on its own too.

    Now, I want to type this...


    and have my nice web app INDEX.JSP come up on the screen.

    But no. I get a blank page instead. I figured this is because there was no trailing slash so I tried


    No go. FINALLY I tried


    IT WORKS!!! But no good to me. I need the URL operational without the INDEX.JSP part.

    Things tried so far...

    1) added index.jsp to Apache DirectoryIndexes and added Indexes to the Options of the Directory element that maps to my htdocs root.

    2) Tried using the Alias and RewriteEngine to map /webappname to /webappname/index.jsp. No go.

    3) Tried using a symbolic link to index.jsp in htdocs/webappname. NO GO (you can see why I am pissed off)

    4) Tried kicking and punching the screen several times and threatening it. Did not work.

    Useful information....

    1) I had this working in Apache 1.3 by setting the ServerName ti the IP address (this I already did in my new Apache 2 httpd.conf)

    2) Apache 2 access log shows my requests without the index.jsp on the end as Http Error 302 which is some sort of Moved Temporarily error.

    3) Tomcat acccess log does not register anything unless the index.jsp is put on originally. This means that Tomcat is not even getting the requests where index.jsp is left off.

    4) I am using the warp web_app module to map to web apps. My URL paths only work when I have a trailing slash on them like this;

    WebAppDeploy webappname warpConnection /webappname/

  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2001
    Jenbach, Austria
    Rep Power

    Check Apache httpd.conf

    Hi there,

    i had an similary problem with my PHP-scripts after the installation of apache 2.0.35. i think the solution of the problem was to set the dot before the extensions in AddType like this:

    AddType application/x-httpd-php .php4 .php .php3 .phtml

    ( the old version : AddType application/x-httpd-php php4 php php3 phtml )
    welcome to the real world

IMN logo majestic logo threadwatch logo seochat tools logo