#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2002
    Location
    United States of Europe (USE)
    Posts
    4
    Rep Power
    0

    Setting up Apache 2.0.43 and Tomcat 4.1.12 on Windows


    After much searching and pulling out of hair, I discovered this document, and found it to be really useful.

    I had found the official documentation, complicated and unfriendly towards Windows users. This documentation was refreshingly different.

    The versions specified in the document weren't the latest, but I tried it with apache 2.0.43 and tomcat 4.1.12 on Win2K and it worked. So I hope it proves useful to other newbies.
    Last edited by delboy_trotter; October 22nd, 2002 at 10:46 AM.
  2. #2
  3. An Ominous Coward
    Devshed Specialist (4000 - 4499 posts)

    Join Date
    Jan 2002
    Posts
    4,425
    Rep Power
    0
    Thanks delboy, it's always nice to have some extra documentation links to help answer questions a little quicker (or to point people who don't read it in the right direction )
  4. #3
  5. Modding: Oracle MsSQL Firebird
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2001
    Location
    Outside US
    Posts
    8,527
    Rep Power
    539
  6. #4
  7. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2002
    Posts
    410
    Rep Power
    19

    Unhappy The Document does work


    I followed the instruction of the document named how2install_apache_w_php_jsp_support.doc but I had trouble

    my mod_jk.conf-auto is

    <IfModule !mod_jk.c>
    LoadModule jk_module "C:/WINNT/system32/mod_jk2-2.0.43.dll"
    </IfModule>
    JkWorkersFile "C:/Program Files/Apache Group/Tomcat 4.1/conf/workers.properties"
    JkLogFile "C:/Program Files/Apache Group/Tomcat 4.1/logs/mod_jk.log"
    JkLogLevel info
    JkMount /manager ajp13
    JkMount /manager/* ajp13
    JkMount /examples ajp13
    JkMount /examples/* ajp13
    JkMount /tomcat-docs ajp13
    JkMount /tomcat-docs/* ajp13
    JkMount /webdav ajp13
    JkMount /webdav/* ajp13
    JkMount /*.jsp ajp13

    And I edited the http.conf and inserted,
    Include "C:\Program Files\Apache Group\Tomcat 4.1\conf\mod_jk.conf-auto"

    When I tested the http.conf, as a result, it prompted
    "C:\Program Files\Apache Group\Apache2\bin\Apache.exe" -t -f "C:\Program Files\Apache Group\Apache2\conf\httpd.conf" -d "C:\Program Files\Apache Group\Apache2\."
    Syntax error on line 2 of C:/Program Files/Apache Group/Tomcat 4.1/conf/mod_jk.conf-auto:
    Cannot load C:/WINNT/system32/mod_jk2-2.0.43.dll into server: %1 is not a valid Win32 application.

    the file mod_jk2-2.0.43.dll was downloaded from http://jakarta.apache.org/builds/jak...0.2/bin/win32/

    What is wrong?
    ------------------------------------------
    Perl Kids Kiss Perl
    Stanley
    ------------------------------------------
  8. #5
  9. No Profile Picture
    Some guy
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2001
    Location
    North America
    Posts
    4
    Rep Power
    0
    Stanley1610:

    mod_jk2-2.0.43.dll is not the same as mod_jk-2.0.43.dll

    for the discussed instructions to work, you need to download mod_jk, not mod_jk2

    You may get the latest win32 binary version of mod_jk here:
    http://jakarta.apache.org/builds/jak..._jk-2.0.43.dll

    I hope that this clarification helps.
  10. #6
  11. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2003
    Location
    Chicago
    Posts
    1
    Rep Power
    0
    Hi,
    I'm a newbie to Struts. I installed Apache 2.0, I copied the connector
    in my D:\WINNT\SYSTEM32 foler, I installed tomcat 4.1. When I run a
    sample jsp (without struts code), it worked fine. But, when I tried to
    execute a simple jsp with this code in it
    <%@ page language="java" %>
    <%@ taglib uri="/WEB-INF/struts-bean.tld" prefix="bean" %>
    <%@ taglib uri="/WEB-INF/struts-html.tld" prefix="html" %>
    <%@ taglib uri="/WEB-INF/struts-logic.tld" prefix="logic" %>
    <html:html locale="true">
    <head>
    <html:base/>
    <title>
    <bean:message key="index.title"/>
    </title>
    </head>
    <body>
    <h2>BookView</h2>
    </body>
    </html:html>

    When I run this jsp, it gave me error "Cannot find message resources
    under key org.apache.struts.action.MESSAGE". Any help is appreciated.

    Thanks
    Kumar
    630-729-9626
    rangak@indianews4u.com

IMN logo majestic logo threadwatch logo seochat tools logo