#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2003
    Posts
    3
    Rep Power
    0

    Question problems editing jsp file


    we took over a site. tried to edit the jsp fields and the java went weird! un did all the edits sent the pages back and still doesn't work. we get this error:
    Internal Servlet Error:

    org.apache.jasper.JasperException: Unable to compile class for JSP/usr/ngasi/contexts/arieslingerie/private/tomcat/work/t32/localhost_8080%2Farieslingerie/_0002fBasket_0002ejspBasket_jsp_15.java:14: Package bean not found in import.
    import bean.*;
    ^
    /usr/ngasi/contexts/arieslingerie/private/tomcat/work/t32/localhost_8080%2Farieslingerie/_0002fBasket_0002ejspBasket_jsp_15.java:15: Package util not found in import.
    import util.*;
    ^
    2 errors

    here's the header


    <head>
    <%@ page import="java.sql.*"%>
    <%@ page import="bean.*"%>
    <%@ page import="util.*"%>

    </head>
    <body bgcolor="#dc29bb">
    <form action="form.jsp" method="get" name="form1">
    <jsp:useBean id="basketPrice" scope="session" class="java.util.Vector" />
    <jsp:useBean id="basketCode" scope="session" class="java.util.Vector" />



    any ideas what we can try. the web-inf classes folder is empty!
    tomcat32 is running
    Thanks
    Matt
  2. #2
  3. No Profile Picture
    Clueless llama
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Feb 2001
    Location
    Lincoln, NE. USA
    Posts
    2,353
    Rep Power
    117
    Hmm. The WEB-INF should not be empty. There should be a web.xml file in it and a classes and lib folder at least. Somehow that stuff got deleted. The packages it says it can't find should be in the classes directory or in a jar file in the lib folder. Hope you have a backup.
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2003
    Posts
    3
    Rep Power
    0
    it's suddenly started working again. sorry to be vague we have a web.xml and lib & classes folders (but these folders are empty).
    We think the tomcat needed restarting and our ISP would only offer supprot at $100 an hour and no help files.
    It was webappcabaret
    Out of the 6 ISP I use I would give them a 0 out of 10 and strongly advise EVERYBDOY not use them unless you have lozts of moeny and like people being unhelpfully arrogant.
    Thanks for taking the time NEMI.
    Matt
  6. #4
  7. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2003
    Posts
    3
    Rep Power
    0
    hey found the reason why it's working a´gain all the claases are back in the classes folder must hae been a backup by the server...
    Matt

IMN logo majestic logo threadwatch logo seochat tools logo