#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2004
    Posts
    3
    Rep Power
    0

    Angry Active Directory (Microsoft LDAP SDK) : Problem with ldap_bind_s


    I am binding a user with correct password to active directory(SSL enabled). The user's
    attribute “User Must Change password at next logon” is set (i.e. pwdLastSet=0).

    lderr = ldap_bind_s(ld, (char *) (LPCTSTR) szPath,(char *) (LPCTSTR) szPassword, LDAP_AUTH_NEGOTIATE);
    ldap_get_lderrno(pld->m_pLdap, NULL, &szErrmsg);

    I get:
    1. lderr = 49
    2. szErrmsg = "8009030C: LdapErr: DSID-0C0903E2, comment:
    AcceptSecurityContext error, data 0, v893"

    Problem :
    The error message I got is same when I try to bind a user with wrong password and whose attribute pwdLastSet= -1.
    How will I distinguish that user login is rejected due to bad password or pwdLastSet=0 ?

    I am sure there is no problem with SSL or other AD configuration.

    Please Help
  2. #2
  3. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2005
    Posts
    1
    Rep Power
    0

    Problem with "pwdLastSet=0"


    Hi!

    My problem:
    I try to connect to an ad server over SSL and ldapv3. The problem is the interpretation of the answer from the ad server. The perl modules return me the error 49, but the user and password is correct, and "pwdlastset=0".

    During my search for a solution for my problem, I found your posting about the same problem I actually have, but no replies.
    So I hope you have a solution and can already tell me your solution.

    regards
    paul holzhacker

IMN logo majestic logo threadwatch logo seochat tools logo